Node not starting IPSubscriptionTarget

Redownloaded configs, worked yesterday, was synced and all, my BP on other server works

[relay-no:cardano.node.networkMagic:Notice:5] [2021-02-25 17:16:18.54 UTC] NetworkMagic 764824073
[relay-no:cardano.node.basicInfo.protocol:Notice:5] [2021-02-25 17:16:18.54 UTC] Byron; Shelley
[relay-no:cardano.node.basicInfo.version:Notice:5] [2021-02-25 17:16:18.54 UTC] 1.24.2
[relay-no:cardano.node.basicInfo.commit:Notice:5] [2021-02-25 17:16:18.54 UTC] 400d18092ce604352cf36fe5f105b0d7c78be074
[relay-no:cardano.node.basicInfo.nodeStartTime:Notice:5] [2021-02-25 17:16:18.54 UTC] 2021-02-25 17:16:18.543260952 UTC
[relay-no:cardano.node.basicInfo.systemStartTime:Notice:5] [2021-02-25 17:16:18.54 UTC] 2017-09-23 21:44:51 UTC
[relay-no:cardano.node.basicInfo.slotLengthByron:Notice:5] [2021-02-25 17:16:18.54 UTC] 20s
[relay-no:cardano.node.basicInfo.epochLengthByron:Notice:5] [2021-02-25 17:16:18.54 UTC] 21600
[relay-no:cardano.node.basicInfo.slotLengthShelley:Notice:5] [2021-02-25 17:16:18.54 UTC] 1s
[relay-no:cardano.node.basicInfo.epochLengthShelley:Notice:5] [2021-02-25 17:16:18.54 UTC] 432000
[relay-no:cardano.node.basicInfo.slotsPerKESPeriodShelley:Notice:5] [2021-02-25 17:16:18.54 UTC] 129600
[relay-no:cardano.node.basicInfo.slotLengthAllegra:Notice:5] [2021-02-25 17:16:18.54 UTC] 1s
[relay-no:cardano.node.basicInfo.epochLengthAllegra:Notice:5] [2021-02-25 17:16:18.54 UTC] 432000
[relay-no:cardano.node.basicInfo.slotsPerKESPeriodAllegra:Notice:5] [2021-02-25 17:16:18.54 UTC] 129600
[relay-no:cardano.node.basicInfo.slotLengthMary:Notice:5] [2021-02-25 17:16:18.54 UTC] 1s
[relay-no:cardano.node.basicInfo.epochLengthMary:Notice:5] [2021-02-25 17:16:18.54 UTC] 432000
[relay-no:cardano.node.basicInfo.slotsPerKESPeriodMary:Notice:5] [2021-02-25 17:16:18.54 UTC] 129600
[relay-no:cardano.node.addresses:Notice:5] [2021-02-25 17:16:19.53 UTC] [SocketInfo 0.0.0.0:3001]
[relay-no:cardano.node.diffusion-mode:Notice:5] [2021-02-25 17:16:19.53 UTC] InitiatorAndResponderDiffusionMode
[relay-no:cardano.node.dns-producers:Notice:5] [2021-02-25 17:16:19.53 UTC] [DnsSubscriptionTarget {dstDomain = "relays-new.cardano-mainnet.iohk.io", dstPort = 3001, dstValency = 2}]
[relay-no:cardano.node.ip-producers:Notice:5] [2021-02-25 17:16:19.53 UTC] IPSubscriptionTarget {ispIps = [], ispValency = 0} ```




after waiting a long time it says

cardano-node: symbol lookup error: cardano-node: undefined symbol: crypto_vrf_publickeybytes


pls help
4 Likes

If it continues from there after 15min or so it would be a sign of a hard shutdown. The node didn’t have a chance to do a graceful shutdown and remember the last good state of the blockchain. On restart, it re-scans and verifies all the block data again - this takes a while.

If you are running the inputoutput/cardano-node image, this would be a known bug #2353

1 Like

Hi, have you fix it? I have the same situation

1 Like

Try updating

cd cardano-node

git fetch --all --tags

git tag

git checkout tags/<latest-version(1.25.1 currently)>

cabal update

cabal build cardano-node cardano-cli

backup your current binaries (in case you have to revert to an earlier version).

cd ~/.local/bin

mv cardano-cli cardano-cli-backup

mv cardano-node cardano-node-backup

Now copy your newly built binaries to the appropriate directory, with:

cp -p dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-node-<latest-version(1.25.1 currently)>/x/cardano-node/build/cardano-node/cardano-node ~/.local/bin/

cp -p dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-cli-<latest-version(1.25.1 currently)>/x/cardano-cli/build/cardano-cli/cardano-cli ~/.local/bin/
1 Like

Hi @tomdx
How to “graceful shutdown” once I run the node using “cardano-node run …” ?

You watch the log and in a different terminal you do docker stop .... The log should say “Shutting down…”. Don’t do docker rm -f ..., which will shortcut the 10sec grace period that docker gives the process to cleanly shut down. It would leave your blockstore in a dirty state, which would require validation on startup, which might take >1h

1 Like