Noob guide for air gapped machine

Hello
is there a noob guide for making an air-gapped machine?

I get files from the server by the command scp, then i navigate my terminal to Cardano cli folder, but when i run key generation commands:
cardano-cli shelley node key-gen
–cold-verification-key-file node.vkey
–cold-signing-key-file node.skey
–operational-certificate-issue-counter node.counter

it tells me no commands found.

Hi Hakkija,

I hope I did not miss your question. The solution would be to copy the executable cardano-cli from your hot environment to your cold environment.

Best,
Johann

Hello Johan
i download directory from node server to my linux computer, but still cant run it trough terminal.

Best regards,
Henri

Hi Henri,

You need your cardano-cli executable.
Run the command in the shell:
which cardano-cli
on your server where it is installed. This will promt you the location of the executable.
Copy this cardano-cli to your cold environment.

I hope this helps you.

Best,
Johann

Thank you Johann
it looks different directory then i downloaded, i will try now.

Hello

still nothing, i downloaded the binary executable file, but when i run commands in the same folder it states:
henri@henri-laptop:/media/henri/scan$ cardano-cli shelley node key-gen
> --cold-verification-key-file node.vkey
> --cold-signing-key-file node.skey
> --operational-certificate-issue-counter node.counter
cardano-cli: command not found

is there a command how to run the executable file?

now it generated files, but they are empty and filesize is 0bytes.
henri@henri-laptop:/media/henri/scan$ ls
cardano-cli --cold-verification-key-file
–cold-signing-key-file --operational-certificate-issue-counter

Hi Henri,

to run an executable you should type
./cardano-cli

the dot and the slash infront of cardano is important

Best,
Johann

Hello Johann

i think i needed wineHQ for that, im downloading it.
got error that i dont have executable software on linux.
cancel that. :smiley:
when i run ./cardano-cli it tells me i dont have permissions, when i do sudo, it tells me there is no command like that in cardano-cli

Hello,
i think i finally got it, problem was when i copied cardano-cli to usb stick it changed permission to read only and i could not change it. i did keys on my laptop and now will move them to usb.
Thank you!