NOT A BLOCK PRODUCER! RELAY ONLY!

Hello all,
The relay node is connected to the other internet relays, the BP node shows it’s connected to the my relay too, but in the liveview.sh I see " NOT A BLOCK PRODUCER! RELAY ONLY! ", what can be the cause of this?

image

Here is the output of the Grafana:

and Cardano RTView:

My relay and BP nodes are on the same machine but are running on different ports, the relay is listening on port 3001, BP on port 6000. I don’t see any misconfiguration here.

Thanks guys!

What a stupid mistake reading last post of this thread Core seems to be set as Relay - #8 by Alexd1985 I found I have same issue:

cardano-node run
–topology /home/cardano-producer/config/mainnet-topology.json
–database-path /home/cardano-producer/db
–socket-path /home/cardano-producer/db/node.socket
–host-addr 0.0.0.0
–port 6000
–config /home/cardano-producer/config/mainnet-config.json
–shelley-kes-key /home/cardano-producer/keys/kes.skey
–shelley-vrf-key /home/cardano-producer/keys/vrf.skey
–shelley-operational-certificate /home/cardano-producer/keys/node.cert

must be:
cardano-node run
–topology /home/cardano-producer/config/mainnet-topology.json
–database-path /home/cardano-producer/db
–socket-path /home/cardano-producer/db/node.socket
–host-addr 0.0.0.0
–port 6000
–config /home/cardano-producer/config/mainnet-config.json \
–shelley-kes-key /home/cardano-producer/keys/kes.skey \
–shelley-vrf-key /home/cardano-producer/keys/vrf.skey \
–shelley-operational-certificate /home/cardano-producer/keys/node.cert

I forgot to add the linebreaks “” at the end of each parameter :frowning:

Thank you guys anyway!

I’m very happy :slight_smile:

image