Block-Producer shown as "Relay-Mainnet" in gLiveView

I have configured 1 block-producer node and 2 relay nodes on three separate servers. I configure the nodes for all three and they all running and syncing fine except for the BP node showing as “Relay - Mainnet” instead of “Core”.

I have follow Coincashew’s step-by-step and I have tried to re-run/re-create many time but end result still the same: Block-producer showing as relay.

I am attaching few screenshots for you guys to review. Thank you in advance.

Screenshot from 2021-02-23 21-57-57

That’s because you started as a relay
You must start it like a Producer, right? For this you need to update the script.

image

https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node
Chapter 9

Cheers,

Hi folks, my block producer started as Relay as well. but I was following cntools tutorial. Please help.
3

1

type… cd $CNODE_HOME/priv/pool
And then ls -l

show me the folder name

4

Ok, probably u didn’t knew it but in env pool name is case sensitive… so write the pool name exactly like the name of the pool folder… save the file and restart the node

cd $CNODE_HOME/scripts

nano env

OMG!!! Man you are right. Thanks man!!!
So much time was waisted. I have seen a lot of your posts you are a superstar here.

2 Likes

Alex could tell why my BP node does not have processed TX5

Because ur relay also does not?

This is how my Relay looks like 6

Yes, no in connections… what is ur ticker?
What is the last log message from topology updater script?

cd $CNODE_HOME/log

Ticker KAI1 but I am not able to find it in Daedalus also I am able to find it in the pooltools
In the Logs folder on the relay I have the following which file should I open ?7

Topology_updater…

Sorry, here you go.

Ok, tey to testart the node snd check again in glive

cd $CNODE_HOME/scripts

sudo systemctl restart cnode

After few minutes check in glive

It is working now. Thanks a lot.

1 Like

Hi Alex,
You are the wizard!! you know exactly what it is by looking at the screenshots. Yes, I stopped at step 8 and run gLive then scream instead of continue to work on step #9. Thanks again.

1 Like

Hi i followed the stakepool247 guide but i have the same issue my block producer showed Relay-mainnet in gliveview. i updated my script node.sh with kes vrf and cert but i dont know what is the problem. could you help me?Untitled

Can u show me the cnode script?

Cheers,