Block Producing Node "Relay - Mainnet" instead of "Core - Mainnet" (CoinCashew Guide)

I am following the CoinCashew Guide (Guide)

I am stuck at step 8.

I am able to get the relay node synced (figure 1).
I am also appear to be able to get the block producing node synced (figure 2). But, as can be seen in figure 2, the gLiveView displays “Relay - Mainnet” instead of “Core - Mainnet” (as referenced in step 8).
Please can someone advise?

I have set my AWS Ubuntu 20.4 Server’s security groups for the relay node to be able to communicate with the block producing node and anybody else.
The security group for the block producing node is such that it only communicates with the relay node and nothing else.

Both nodes can communicate with each other.
On relay Node:
netcat -vnz 6000
Connection to 6000 port [tcp/*] succeeded!

On Block producing node:
netcat -vnz 6000
Connection to 6000 port [tcp/*] succeeded!

Figure 1 (relay node)

Figure 2 (block producing node)

Relay node topology:

Block producing topology:

There is another script to start the node as a Producer, did u used it? If yes, then check the path to the files.

@Alexd1985 I used the following to start both the relay and block producing node:
sudo systemctl start cardano-node
Is this what you are referring to?

Nope, the script which u configured to start the node… with configuration file, port, topology, etc

But I see it is at the end of step 9 so keep going through the guide :wink:

@Alexd1985 ok. But before proceeding to step 9, do i have to wait for the nodes to fully sync up?

Yes, u should wait to be synced then u can create the keys

See the message from the end of step 8

Congratulations! Your node is running successfully now. Let it sync up.

1 Like

Hey @Alexd1985; I read your answers in almost all similar problems but I am facing a relatively different problem.

I was in step 14 of the COINCASHEW tutorial, and my block producer and relay were working well, my unique problem was that the Process TX was 0 in both instances…

After some readings, I tried to modify the port of the relay on my BP instance (as step 4 of the tutorial); So I tried to run again the step Start the nodes (step 8 in the tutorial), but when I did run the ./ I did note that my Block Producer becomes a relay node;

Could you please give me any light on how to solve this?!

Should I run everything again and recreate all the keys?!?!?!

Any help would be really appreciated, I really do not know how to solve this and I have tried a lot

Nope, but use the blockProducer script to start the node, and yes it looks like a relay till the node will start again… is the node up and synced?

Hey Alex!! Thank you very much for your fast reply mate;

Yes, the both nodes are synced:

About the start block producer node script, are you meaning about this?
● cardano-node.service - Cardano node service
Loaded: loaded (/etc/systemd/system/cardano-node.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2021-05-24 13:55:28 UTC; 6min ago
Main PID: 1507522 (startBlockProdu)
Tasks: 12 (limit: 9449)
Memory: 2.3G
CGroup: /system.slice/cardano-node.service
├─1507522 /bin/bash /root/cardano-my-node/
└─1507523 /usr/local/bin/cardano-node run --topology /root/cardano-my-node/mainnet-topology.json --database-pa>

I re-did all the topic 7 and 8 steps but still showing the same results as above…

I have a fear to do something wrong that will make me lose my money on this account, idk

Thank you in advance bro;


and show me the output


The complete content is:

cat > $NODE_HOME/ << EOF
/usr/local/bin/cardano-node run --topology ${TOPOLOGY} --database-path ${DB_PATH} --socket-path ${SOCKET_PATH} --host-addr ${HOSTADDR} --port ${PORT} --config ${CONFIG}

you missed to update the keys inside the script

Update your startup script with the new KES, VRF and Operation Certificate.

block producer node

cat > $NODE_HOME/ << EOF











cardano-node run --topology \${TOPOLOGY} --database-path \${DB_PATH} --socket-path \${SOCKET_PATH} --host-addr \${HOSTADDR} --port \${PORT} --config \${CONFIG} --shelley-kes-key \${KES} --shelley-vrf-key \${VRF} --shelley-operational-certificate \${CERT}


update the script and restart the node

sudo systemctl restart cardano-node

1 Like

It worked smoothly ;
Thank you very much for your support!!! You’re the best

1 Like

you are welcome, anytime

1 Like

I have the same problem and I’m stuck with Relay-Mainnet instead of Core-Mainnet. I have one block producer and one relay node. I followed the CoinCashew Guide and this video:

I don’t find something wrong and I have the keys in my startBlockProducingNode script.
I regenerated the keys and the node.cert with the CoinCashew Guide just for sure but I still have the issue. I also did the Configuring Network Topology in the Part III of the guide.


Must be an issue with the path for BP files inside the start script


Here is on my Block Producer:

It’s the start script that you talked about?

But this script doesn’t have the the lines for the new keys. Is it normal?


This is it (for BP) yes

This is for relays