Not able to get the the transaction hash

Hi Thomas,

Your node needs to sync to a point past where the transaction block occurred in order to see the transaction has taken place.

Let your node sync to tip and they try again.

1 Like

Ok I will try. In reality CPU usage turned back from 100% to 2% and I was at epoch 211, so I thought I was already completely synced. Is there a way to know that I am completely synced?

It doesn’t look to be syncing… It’s been up for 8 hours and I’m still at epoch 0, although I have it running because I see CPU usage percentage vary between 4 and 10% constantly, but still at epoch 0. Donno what happened.

What’s the result of running this command?

cardano-cli shelley query tip --mainnet

Also, you can compare tip with the block height on or, or with your other nodes if you are running multiple instances

1 Like

I get this error message: cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory).
Although I had exported the CARDANO_NODE_SOCKET_PATH correctly. This happened though to me in the past, sometimes it disappears and everything works fine and sometimes it comes back

Hi Thomas,

This sounds like your node is cycling restarting intermittently

cardano-cli: Network.Socket.connect: <socket: 11>: error often occurs when the node is down

My guess is you either have some issues with your libsodium configuration or are running parallel instances of the node which are conflicting with each other.

Please check this post for a solution to a potential issue with your libsodium config:

And if that doesn’t work, try running killall cardano-node and then restart your node to see if the problem persists

Your friend, FROG


I do not have a .bash_profile file. For the modification of the .bashrc file and sourcing the file, I already did that upon installation as requested within the guide

Edit: .profile is the equivalent of .bash_profile. I’ll try it and come back to say what happened.

No it doesn’t work, neither killall works. The node looks like it’s working from graphics but nothing is happening. And I can see I am connected to no peer addresses. At some points during syncing I got disconnected wondering if that made this bug.

Ok, I created an empty node.socket file in the db folder, and ran it again, so it started working, but back to epoch 0… Hopefully this time goes until the end without any disconnections from my side.

Thank you ADAfrog for helping.


My pleasure, Thomas. Let us know if you run into further issues.


Hi ADAfrog,
In order for me to verify what’s happening, I ran 2 nodes, one in my VirtualBox, and the other on my VPS. They both have 4GB RAM allocated (each one of them). They sync with the blockchain without any issue until epoch 211 slot 444, and then all of a sudden everything stops (on both independent servers), all peers disappear, but the node is still running (“cardano-cli shelley query tip --mainnet” gives the correct block number).

It looks like more of a Network problem?

Edit: My Cardano-node version:
cardano-node 1.18.0 - linux-x86_64 - ghc-8.6

git rev 468f52e5a6a2f18a2a89218a849d702481819f0b

Sounds to me like you’re in sync and on tip

No I am stuck at block 4555199 and slot 5789244 (for both servers). Same problem doesn’t give transaction hash. There has been some posts on this forum like this but it said you shouldn’t run Cardano-node v.1.18.1 but 1.18.0, but this is what I have.

Hi Thomas,

Assuming you tried restarting the nodes and the problem persists, have you checked to ensure external ports are open on your relays externally?

Are there any clues you can provide in your log files?

Also, on a side note, have you ever ran 1.18.1 on these nodes?

Please refence this thread as well - if all else fails you may want to try deleting the db directory and starting over:

I have checked the website you provided and port 3001 is connected to my external IP address (if that’s what you meant)
As far as my log files are concerned, I think I’ll get lost with this one (unless you specify what exactly I should be looking for). But the story is both independent servers got stuck at the exact same slot… This means the problem comes probably from outside, either installation of software or network.

I just built my software once and it’s this version 1.18.0. But there seems like from what is said on the thread you provided that it is not enough for it to be 1.18.0, and we must be checking GitHub for something else (they were talking about the “git rev” that is something I don’t understand). So in fact for the node to run does the version have to be the exact last one?

I might rebuild everything from scratch if that’s the case.

The port should show as “open” when you use the port checker too above.

If the port is indeed open, I would try deleting the cardano-node/db folder and restarting the node

Yes the status is “open”. Are you sure I should just delete the db and start the node again and not build the binaries again? My version is:

cardano-node 1.18.0 - linux-x86_64 - ghc-8.6
git rev 468f52e5a6a2f18a2a89218a849d702481819f0b

yeah just trash the db

Done. The node is starting to sync again from 0. I will cross my fingers and come back with the news of what happened.

Thank you ADAfrog.

1 Like

Network is fine.

What resources are you running on your machine (RAM, cpu, etc)?

I would double check your firewall settings, and yes, assuming all is well there, stop the node and delete the database again (rm -R /path/to/cardano-node/db).

On a side not, I strongly recommend not running as root user, as well as avoid storing your keys on an internet connected machine.

Your friend, FROG