Updating stake pool school Config files

Thanks Andy!

When trying to follow the course you were correct in that the “start your node” section will not work as the command references files that do not exist. I tried your suggestion above and found that it worked!

cardano-node run
–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–host-addr x.x.x.x
–port 3001
–config testnet-config.json

1 Like

So now that my node is up:

Its saying that I’m on both the Byron and Shelley release at the top of the screen in LiveView and it is connected to the blockchain.

I’m having trouble running cardano-cli; cardano-cli shelley now. Unable to generate keys…

Will the school be updating the course? I might need to start over.

1 Like

Yes, after starting the node for the first time all following commands get response
“cardano-node: error while loading shared libraries: libsodium.so.23: cannot open shared object file: No such file or directory”

1 Like

This may be a different issue:
Did you build and install libsodium

  cd ~; mkdir git ; cd git;
  git clone https://github.com/input-output-hk/libsodium
  cd libsodium
  git checkout 66f017f1
  sudo make install

Yes, that was done before.
I don’t get that message before running the node. Only after the node has been run I start getting it. After starting then stopping the node a couple times I can no longer start the node. Just keep getting that message.

same with me, after rebooting
I did the steps 9 and 10 of the libsodium installation:
export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
inside libsodium directory
and than the cardano-node command worked
but don’t know how to fix it permanently

Just add this to your .bashrc (and then source .bashrc to take effect same session)

export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"


can you try adding this to your .bashrc and source it:
export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"

and within your .bash_profile add:
test -f ~/.bashrc && source ~/.bashrc


Thanks ADAfrog!

Here is how I implemented that solution.

nano .bashrc

scroll to bottom and paste these two lines

export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"

Press control-x to exit
Press y to save
Press enter to confirm save

nano .bash_profile

scroll to the bottom and paste

test -f ~/.bashrc && source ~/.bashrc

Press control-x to exit
Press y to save
Press enter to confirm save

sudo reboot

Reboot command will restart your machine.
Close and reopen your terminal window.
Wait a couple minutes then log back into your machine.

I could be wrong about the implementation, though. I’m a noob myself.


Thanks both! Thats work like a charm!

1 Like

Configure Topology Files for Relay and Block Producing Nodes:


This section script will not work. I used the main net version instead:

wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-config.json
wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-byron-genesis.json
wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-shelley-genesis.json
wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-topology.json
1 Like

change “sudo reboot” to “source .bash_profile”

nice work!

1 Like

Anyone get this error on node start up?

[ip-172-3:cardano.node.release:Notice:5] [2020-08-11 23:09:01.75 UTC] CardanoProtocol
FsError {fsErrorType = FsInsufficientPermissions, fsErrorPath = /db, fsErrorString = “Permission denied”, fsErrorNo = Just (Errno 13), fsErrorStack = [(“ioToFsError”,SrcLoc {srcLocPackage = “ouroboros-consensus-”, srcLocModule = “Ouroboros.Consensus.Storage.FS.IO”, srcLocFile = “src/Ouroboros/Consensus/Storage/FS/IO.hs”, srcLocStartLine = 88, srcLocStartCol = 41, srcLocEndLine = 88, srcLocEndCol = 68}),(“handleError”,SrcLoc {srcLocPackage = “ouroboros-consensus-”, srcLocModule = “Ouroboros.Consensus.Storage.FS.IO”, srcLocFile = “src/Ouroboros/Consensus/Storage/FS/IO.hs”, srcLocStartLine = 84, srcLocStartCol = 23, srcLocEndLine = 84, srcLocEndCol = 38}),(“rethrowFsError”,SrcLoc {srcLocPackage = “ouroboros-consensus-”, srcLocModule = “Ouroboros.Consensus.Storage.FS.IO”, srcLocFile = “src/Ouroboros/Consensus/Storage/FS/IO.hs”, srcLocStartLine = 65, srcLocStartCol = 54, srcLocEndLine = 65, srcLocEndCol = 71}),(“createDirectoryIfMissing”,SrcLoc {srcLocPackage = “ouroboros-consensus-”, srcLocModule = “Ouroboros.Consensus.Storage.FS.API”, srcLocFile = “src/Ouroboros/Consensus/Storage/FS/API.hs”, srcLocStartLine = 123, srcLocStartCol = 5, srcLocEndLine = 123, srcLocEndCol = 29})], fsLimitation = False}

cardano-node: FsInsufficientPermissions for /db: Permission denied at CallStack (from HasCallStack):
ioToFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:88:41 in ouroboros-consensus-
handleError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:84:23 in ouroboros-consensus-
rethrowFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:65:54 in ouroboros-consensus-
createDirectoryIfMissing, called at src/Ouroboros/Consensus/Storage/FS/API.hs:123:5 in ouroboros-consensus-[ec2-user

Did you check that the user you run the cardano-node has write to /db ? maybe instead of /db you should user ~/db or ~/node/db

1 Like

Thanks! it was because I was mixing mainnet files with testnet. Is there a tutorial for that is up to date for creating a mainnet stake pool?

Got it, thanks!


Devin Sumaoang

This worked fantastically! Thank you!

Thank you! :grinning:

This worked ! Thank you!

Thanks ADAfrog !!!