Error while loading shared libraries: libsodium.so.23:

Hello everyone,

I’m currently working on setting-up the second relay node for my stake pool. But for some reason I’m getting this error when trying to run the node for the first time:

ubuntu bash[19812]: /usr/local/bin/cardano-node: error while loading shared libraries: libsodium.so.23: cannot open shared object file: No such file or directory

I’ve already consulted the forum and tried to implement the fix mention in this post Updating stake pool school Config files - #14 by TheAndy but it didn’t work.

Here is a screenshot of my .bashrc file
image

And here a screenshot of bin and lib folders
image

Thanks in advance,
Kind regards

Hi There!

can you please give the output of ldd cardano-node
and echo $LD_LIBRARY_PATH

Hi lapasz thank you for your response.
Here is the output of the commands:
image

Hi!

As you can see everything is in place - so can you just call cardano-node version

That’s why I don’t know why it’s not working lol

cardano-node 1.25.1 - linux-x86_64 - ghc-8.10
git rev 9a7331cce5e8bc0ea9c6bfa1c28773f4c5a7000f

so cardano-node called with systemctl?

Yes, I’m using systemctl with the startup script from coincashew guide.

try to make a symlink:
ln -s /usr/local/lib/libsodium.so.23 /lib/x86_64-linux-gnu/libsodium.so.23

or define the env variable in systemctl script:

Environment="LD_LIBRARY_PATH=/usr/local/bin"
ExecStart=...
1 Like

Thanks a lot!! that worked :slight_smile:

1 Like