Official tutorial contains a joke: mistery

This is a real mistery: the tutorial joke!
This page: Official Tutorial contains a joke. In the RAW creating section there is a simple joke.
The joke is this: to create a RAW transaction to submit to the network you need a fee variable calculated; to have the fee calculate you need a raw already maden.
This is a joke! A beautifull joke.

you’re right, it seems to have an impossible step :crazy_face: … I haven’t been through this minting procedure myself, but CLI procedures that transfer funds generally have two building transactions:

  1. the first raw transaction calculates a fee based on the nature of the transaction, the number of addresses & signing keys that will be required, etc. … but without exact amounts in the transaction

  2. the second raw transaction (the one that will be signed) has all those exact amounts based on the fee that is calculated in the first step… including the fee itself.

So I think the first of those cardano-cli transaction build-raw commands should be run after setting fee=0 to generate a “test” raw transaction, which can then be used to calculate the fee as in the tutorial.

Others might not have been bothered by the problem because they’ve already understood the process for basic transactions, as in this earlier official tutorial where it’s easier to see the 2 steps without the native token process. You can see here how the fee is set to zero when the first raw transaction is built: cardano-node/ at master · input-output-hk/cardano-node · GitHub

If others agree (@adatainment?), an issue or pull request should be generated against this page (developer-portal/ at staging · cardano-foundation/developer-portal · GitHub) to add fee=0 before that first transaction building command.

1 Like

During the writing of these posts I understood the joke. I made a 0 fee and I made a raw test. There are too mutch errors. It seem impossible to build an asset. After the fee calculation It seems impossible to submit the signed transaction. I think that the procedure should be revisited and the minting process should be easier to compete with other tokenisation engine. Easier and more rich of features or ptions. The future of the tokenization of the world cannot passes through this way! LOL

The error is the same everytime. I send you an example:

Command failed: transaction submit  Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraMary (ApplyTxError [UtxowFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash "c657603872b36f9d283aa12db8ea91315594ac8733d16f60db40b6c4"])))])

Thanks. I solved by the use of variables. The “export FEE=0” in the code makes easy to calculate the FEE itself because the command for the RAW transaction can be launced again after the exact value of the FEE and of the amount of the transaction.

1 Like

Sorry, it looks like I missed that tag. Could you create a PR for it? (or open an issue in the repo?)

@ruttkowa you may want to double check this.

Hello. I do not understand what you mean. I solved because I understood by myself. Thanks for the reply anyway.

sure, I hope this clarifies things according to my comment above about the reason for the confusion:

1 Like