Operation timed out

I have downloaded the the node and it has synchronised 100%. I have created payment/stake address and keys. While I was working with the node someone accidentaly turned off the wifi. Node was stuck for sometime and suddenly I got an error message ‘Operation timed out’. After that I tried several time to connect to the server, but its still showing the same error message(Operation timed out). I tried rebooting my instance but still unable to establish the connection with the server. My console it shows that the instance is running.

Do anyone know, how to resolve this issue and how to avoid such situation in future.


Perhaps the node has another IP now?
Is it a local node?


I have installed the node in aws server. How the ip of node will change.

Check the IP on aws panel

1 Like

thanks for answering and sorry for the late reply. I deleted my server and started a new server to run the testnet. I started again from step-1.
I’m still in testnet phase.

When i do “nano testnet-topology.json” it shows my add, port and valency as “2”. (I have difficulty in understanding) valency.
In the course it is mentioned as

  1. Make the core node “talk” only to YOUR relay node.
  2. Make your relay node talk to your block-producing node and other relays in the network by editing the testnet-topology.json file:.

How to do above steps 1 and 2.

Valency is amount of connection what your node should establish…

Additionally if you are following manual and stuck somewhere, please provide details what manual you are using…

There are no more testnet network, too. That would imply that you are using some old documentation.

I personally really like coincashew manual. Maybe check it out:

1 Like

Thanks alot

1 Like