Problem setting up a relay node in testnet

Hello! I am trying to set-up my relay node in the testnet. I am following this guide

but when i run de node i get the following error in my terminal:

[ns504988:cardano.node.DnsSubscription:Warning:61] [2021-06-06 23:17:25.96 UTC] Domain: “” Failed to start all required subscriptions

I think everything its fine in my configuration since everything was working well yesterday, but i restarted for installing my firewall ( I opened the port 3001) and today i get this error, also i tried turning off the firewall but that did not help.

I don’t know if is a way to get the IPs and put them in my topology file i have seen that worked for some people before, Is there any other site were i get this IPs needed for my relay start working?

My topology file:

  "Producers": [
      "addr": "",
      "port": 3001,
      "valency": 2

Thank you so much!

Use host-addr when u start the node, and be sure that the fw allow OUT connections for port 3001

Thank you Alex, i tried but no luck, also i changed the valency to 1, that did not work neither, i guess it has some to do with my firewall… i set the port 3001 open from the firewall, is taht equivalent to " fw allow OUT connections for port 3001"?

The problem was that my server included some kind of DNS manager that was not properly working when I installed the firewall. Thank you so much for your help

1 Like