Set maximum IN peers in topologyUpdater?

Hi SPO,

This morning i had 31 IN peers, a lot of duplicate TXs and a big load on CPU, so i had to disable Mempooltrace.

image

Someone knows how to set a maximum IN connections on relays ?

I set the cronjob running topologyUpdater.sh every 6 hours instead 2 hours.

I know this bug is already settled with version 1.26.1 :slight_smile:

1 Like

The topologyUpdater needs to be run once per hour in order to keep your node’s status active.
As far as I know, there is no setting for incomming connections within cardano node. You’ll need to set it in your system by a command like this.
iptables -A INPUT -p tcp --dport XXY -m connlimit --connlimit-above 5 --connlimit-mask 0 -j REJECT

2 Likes

You can also filter to not allow more sessions from same IP but this must be done from ur servers (from iptables)

1 Like

Thank you guys! I used iptables -A INPUT -s peer_IP -j DROP

I dropped 15 peers (unreachable and high RTT)

3 Likes