Setting up Cardano Stake Pool using Ubuntu in BlueOcean

I followed the guides on Prerequisites and Node and CLI on this page:

After I entered “./” it says “Please run as non-root user.

So I created a New User… And followed the steps but I get the following errors when I run this command
$CNODE_HOME/scripts/ -o

This following is the last part of the error:
cp: cannot stat ‘/home/joey/git/cardano-node/dist-newstyle/tmp/src-38863/semigroupoids-5.3.4/dist/setup/setup’: No such file or directory
Copying setup to /home/joey/.cabal/bin/
cp: cannot stat ‘/home/joey/git/cardano-node/dist-newstyle/tmp/src-38863/tdigest-0.2.1/dist/setup/setup’: No such file or directory

Then when I run “cardano-cli version” I got :
cardano-cli: command not found

Where did I do wrong?

Creat a non-root user and do the steps again from the begining… old files can be deleted

Thanks for your reply.

I redid everything from scratch and created non-root user and followed the steps.

But I still get the message … “cardano-cli: command not found”
after running Cardano script
$CNODE_HOME/scripts/ -o

is there something else I need to check?

Also do I create the New user from root?

I need all steps u did and if where errors
U need to do after u are creating the nonroot user and connect on that user

mkdir “$HOME/tmp”;cd “$HOME/tmp”
curl -sS -o

chmod 755
. “${HOME}/.bashrc”

cd ~/git
I remove h from above https link … write it back
git clone ttps://
cd cardano-node

git fetch --tags --all
git checkout 1.24.2
git pull origin master

echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local

Sync the node:

cd $CNODE_HOME/scripts

nano -check/edit the cnode port

create tmux window:
tmux new-session -s session_name

to connect to tmux window:
tmux attach -t session_name

to deattach from tmux:
Ctrl+b d

to see all tmux sessions created:
tmux ls

1 Like

Great! No errors after the last command …

But I have further question, In the instruction when I go to tmux, I should have run “./”

Why is your instruction “nano”?

Lastly what’s next in the process?

I appreciate your patience with a newbie here

Nano before to start the node to check/set the cnode port (default is 6000)
After this u can start the node via tmux or setup as a systemd by running ./deploy-as… script

After u start ur node u can run ./gLiveView script to check the status of ur node… anyway should syncing with the network… it will take more hours…