Stake pool node - cardano-node & Cardano-cli command not found

i completed the initial build and copied the files into the bin dir. Then ran Cardano-cli version and Cardano-node verison both come back with command not found.

why wouldnt these be available now?

Hi!

from https://docs.cardano.org/projects/cardano-node/en/latest/getting-started/install.html

Verify that ~/.local/bin is in your PATH:

echo $PATH

If ~/.local/bin is not in the PATH, you need to add the following line to your .bashrc file

export PATH="~/.local/bin:$PATH"

and source the file:

source .bashrc

I do have it in there with .cabal/ as well

Are both files executable? (chmod +x [filename])

I tried that command as well, no luck.

ok - so give us the output of echo $PATH

User specific aliases and functions

alias rm=‘rm -i’
alias cp=‘cp -i’
alias mv=‘mv -i’

Source global definitions

if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
[ -f “/root/.ghcup/env” ] && source “/root/.ghcup/env” # ghcup-env
PATH=/root/.local/bin:/root/.cabal/bin:/root/.ghcup/bin:/sbin:/bin:/usr/sbin:/usr/bin
export LD_LIBRARY_PATH=/usr/local/lib:
export NODE_HOME=/root/cardano-my-node
export NODE_CONFIG=mainnet
export NODE_BUILD_NUM=5821110
export PATH="~/.cabal/bin:$PATH"
export PATH="~/.local/bin:$PATH"
PATH=/root/.local/bin:~/.local/bin:~/.cabal/bin:/root/.local/bin:/root/.cabal/bin:/root/.ghcup/bin:/sbin:/bin:/usr/sbin:/usr/bin

echo $PATH
/root/.local/bin:/root/.local/bin:/root/.cabal/bin:/root/.local/bin:/root/.cabal/bin:/root/.ghcup/bin:/sbin:/bin:/usr/sbin:/usr/bin

so, then verify the location of the files by calling them with full path
/root/.local/bin/cardano-cli version

My apologies for the delay, the forum was preventing me from responding for 24hrs since I am a community noob.

I don’t see a .local in /root. I tried ls -al but it’s doesn’t show that dir

ok, so what is the echo $USER probably not root…

Hi - I am having the same issues. I cannot start my node nor can I call the cardano-node. System returns:

-bash: cardano-node: command not found

I tried your /root/.local/bin/cardano-cli version but I do not have permission???

echo $USER
ec2-user

can you tell me where you copied the files? to which folder? maybe /home/ec2-user/.bin/ ?

Hi!

So after install what was the command you executed? what your echo $PATH telling?

I ran this without error

sudo cp $(find $HOME/git/cardano-node/dist-newstyle/build -type f -name “cardano-cli”) /usr/local/bin/cardano-cli

where do you get this instruction? do you have a link for that?
so the problem is that PATH does not contain /usr/local/bin

https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node

Just above step 3

Added to bash. Now I am getting: cardano-cli: error while loading shared libraries: libsodium32.so.23: cannot open shared object file: no such file or directory

hmm… libsodium32.so.23 not in LD_LIBRARY_PATH…
let me check the guide…