Installing Node (with AWS Linux) - cabal: command not found

I’m in the process of installing cardano node (already connected to AWS). I’ve already installed all AWS dependencies and have downloaded, unpacked and installed cabal… at the step now in the terminal of cabal update and receiving the error message -bash: cabal: command not found. Tried to confirm cabal --version and again received the message -bash: cabal: command not found. Any guidance on where I’m going wrong?

Kind regards

Hello,
I’m assuming you didn’t miss the part of installing cabal, right? So what very likely is that after installing cabal (before update) you have to put the path into your .bashrc. Either you missed that or you missed “sourcing” this file so that the changes are reflected.

Please have a look at: https://cardano-foundation.gitbook.io/stake-pool-course/stake-pool-guide/getting-started/install-node

hi there

In order for the OS to find an executable without full path, the path to the executable has to be present in the $PATH environment variable. Make sure you have the following:

  1. cabal executable is present at the path you expect it to be
  2. the directory where cabal is located is present in PATH ($ echo $PATH)

If you added the export statement into your .bashrc/.zshrc make sure to run $ source ~/.bashrc to apply your changes.

https://docs.cardano.org/projects/cardano-node/en/latest/getting-started/install.html#download-unpack-install-and-update-cabal

I’m having this same issue and have tried these suggestions, but still getting cabal: command not found. any other suggestions or tips?

Hello,

Please try the following:

add this to your .bashrc:

export PATH="~/.local/bin:$PATH"

and then add this to your .bash_profile:

test -f ~/.bashrc && source ~/.bashrc

and then source your .bash_profile

source .bash_profile