Submit transaction error

It is probably something silly. It is the first time I am submitting transaction after Alonzo. I get this error:

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (ValueNotConservedUTxO (Value 659052171 (fromList )) (Value 159052171 (fromList )))))])

Does it look familiar to anyone. Cannot withdraw the bloody rewards.

please follow this step

18.11 Claim your rewards

I’ve done that 100s of times before. The whole thing is scripted and worked perfectly before. Now it fails after alonzo. Is anything changed with the 1.30 node version?

I also tried a few times today manually - same error

1.30 ? the last version released is 1.29.0

No, the latest is 1.30.0. But that’s irrelevant. I tried on both versions 29 and 30. I think I’ve tried everything by now…

Have you seen this error? Do you know what it means? I am trying to understand what the problem is

can u share the address here?
I think is related with the incorrect amount inserted vs available

I was thinking this as well. But the weird thing, it’s been working since forever perfectly now it fails. I thought maybe something was changed. Something that I missed in CLI or something… who knows…

Payment: addr1q87awedrra9s9c44hszcn94zlcg0dahkt2gtwq0678wktu40uzzgznrs4grqrtuqk7g8tyvjvf8ljsc3tna3pkjpfgcs2l6chn

Stake:
stake1uxh7ppypf3c25psp47qt0yr4jxfxynlegvg4e7csmfq55vgxe4fks

Value 659052171 (total ADA)- is the value controlled by the wallet (all addresses) but your payment address has only Value 159052171 ADA

can you try again? but use 159052171

Hi, I’ve seen this error before and fixed it by adding in an input for the --invalid-hereafter flag that I did by finding the chain tip using cardano-cli query tip --mainnet and adding something like 1000 to the tip. This was when running the cardano-cli transaction build-raw command. Making sure also that the transaction is fully balanced between inouts & outputs & the transaction was successfully submitted. Hope this can help, Simon

I don’t even know where 659052171 comes from…
Yes the sum on the payment is 159052171
The sum on the stake is 500000000

I think the difference is the rewards amount but how the hell does that happened beats me.

Let me try again…

I tried both flags --invalid-hereafter and --ttl … Same error.
Alex, thanks anyway. I’ll fiddle with it a bit more.
If you have any more suggestions please throw them in

try with this value 659052171

1 Like

Your address has only this UTXO

386c166f4792e5b097b8a79a5d712b367f1152a2e7d5fbfdf54266a1565f9d47     
0        
159052171 lovelace + TxOutDatumHashNone

your rewards are 500000000

Your tx-out should be: 159052171 + 500000000 - FEE

Seems like you forgot the transaction fee ?

P.s. the error occurs when the tx-in + withdrawals - fee does not equal tx-out

2 Likes

Yes, you were half right ))
The discrepancy was 500 ada. So the fee was fine but the 500 was missing from the change calculation.

I was merging the old rewards script into another one and screwed up somehow.

I wish I knew what the error meant. It would be much quicker to find the problem. Thank you for the error description, that was useful.

Thanks everyone

1 Like

Glad you resolved it. So whatever is part of TX-IN (ADA + other tokens) must be spent as part of FEES and TX-OUT. Also when minting tokens those must be part of TX-OUT.

If all this does not match the error ValueNotConservedUTxO is returned.

cardano-release-stable

Seems 1.29.0 is still the latest stable for mainnet.

Yeah, one of the things is to decipher the errors first, then it gets easy once you know the problem.

29 is the stable. I was trying the latest one :wink:

[core:cardano.node.networkMagic:Notice:11] [2021-09-23 13:55:43.94 UTC] NetworkMagic 764824073
[core:cardano.node.basicInfo.protocol:Notice:11] [2021-09-23 13:55:43.94 UTC] Byron; Shelley
[core:cardano.node.basicInfo.version:Notice:11] [2021-09-23 13:55:43.94 UTC] 1.30.0
[core:cardano.node.basicInfo.commit:Notice:11] [2021-09-23 13:55:43.94 UTC] 5f0d2401354cbdf2f356be0247fad85c18b717f2