Submitting transaction gives UtxoFailure ValueNotConserved

I am following the CoinCashew Guide and got to the last step to register the stake pool but am facing this error when trying to submit the transaction.

Input command :
cardano-cli transaction submit --tx-file tx.signed --mainnet

Output Error:
Shelley command failed: transaction submit Error: Error while submitting tx: ApplyTxError [LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 10546245241 (fromList [])) (Value 10046245241 (fromList [])))))]

Clearly the amount of ADA is not the issue…

Im guessing it has to do with one of the addresses having an invalid Utxo leftover but im not sure how to rectify the issue.

Thanks in advance.

Using this command to build tx.raw:
cardano-cli transaction build-raw ${tx_in} --tx-out $(cat payment.addr)+${txOut} --invalid-hereafter $(( ${currentSlot} + 10000)) --fee ${fee} --certificate-file pool.cert --certificate-file deleg.cert --mary-era --out-file tx.raw

the 500 ADA for registering the pool were deducted?


Hi There!

please provide the build command with replacing the variables with the values…

I don’t believe it was since my balance is still the same as before the transaction.

txcnt=$(cat balance.out | wc -l)
echo Total ADA balance: ${total_balance}
Total ADA balance: 10546245241

echo txOut: ${txOut}
txOut: 10046038820

as far as I understand the 500 ADA being deducted is the pool deposit but I can’t submit the transaction

ad - what is tx_in

Im not too sure what the values are, I believe it should be the pool deposit
and fee. Since the 345 registration fee ADA was already deducted from the balance.

Unless I am missing something? What is the total ada needed to register stake address and pool? Ive deposited more than I thought I would need but somehow still ended up short and needed to deposit more

What does this command give you back?

cardano-cli query utxo --address $(cat payment.addr) --mainnet --mary-era

500 ADA is the cost for pool registration

Alex, I think he added the pool deposit to the txOut:

1 Like

I ran this command after following
to build the tx.raw

cardano-cli transaction build-raw --tx-in REMOVED#0--tx-out $(cat payment.addr)+9528804139 --invalid-hereafter 25534392--fee 195861 --out-file tx.raw --certificate-file pool.cert --certificate-file deleg.cert

cardano-cli query utxo --address $(cat payment.addr) --mainnet --mary-era

TxHash TxIx Amount

REMOVED 0 10029000000 lovelace
Removed 0 307445241 lovelace
Removed 0 199800000 lovelace
Removed 0 10000000 lovelace

It says the pool deposit is stored in the protocol.json could it be i screwed up in there?

“poolDeposit”: 500000000,
“protocolVersion”: {
“minor”: 0,
“major”: 4
“minUTxOValue”: 1000000,
“decentralisationParam”: 6.0e-2,
“maxTxSize”: 16384,
“minPoolCost”: 340000000,
“minFeeA”: 44,
“maxBlockBodySize”: 65536,
“minFeeB”: 155381,
“eMax”: 18,
“extraEntropy”: {
“tag”: “NeutralNonce”
“maxBlockHeaderSize”: 1100,
“keyDeposit”: 2000000,
“nOpt”: 500,
“rho”: 3.0e-3,
“tau”: 0.2,
“a0”: 0.3

9528804139+195861+500000000=10029000000 - so I think you are fine with the calculations. protocol.json only tells you what is the pool deposit - but right now it is 500 ADA

so are you sure you provided the whole output of the submit command?

Full command submit output:

cardano-cli transaction submit --tx-file tx.signed --mainnet
Shelley command failed: transaction submit  Error: Error while submitting tx: ApplyTxError [LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 10029000000 (fromList [])) (Value 9529000000 (fromList [])))))]

I am very confused tbh

and 345 ADA for registering? Is that all the costs?

strange - the fee somehow not presented in the output