Transaction submit failures

I like this idea saves time. I did fill that that address, I will check perhaps it already went in to that wallet. Deadalus has crashed my computer so will restart and check it. Thanks also for the logic on sending the tokens.

BTW is there a variable for token amount = ?
Not Lovelace amount ?

In my examples it’s amount= and then used with $amount. Minting Native Assets | Cardano Developer Portal uses tokenamount=.

These guides (and the questions on them in these forums) tend to be a wild mixture of Cardano-specific things and general “How does that shell/bash/zsh/Linux thing work?” questions.

cardano-cli does not care if you put that in a variable or in a file or copy and paste it directly.

It just cares that it is after the + and before the space in --txout (and before the space in --mint if you are minting).

1 Like

Thanks you are very good at explaining so much better than following those developer docs :slight_smile:

I did get the transaction after using your method…

Screenshot 2022-01-14 at 11.26.23

So next I need to build the policy metadata with the Time locking values, although the lock only applies to the policy itself not the token which appears can be sold whenever.

I may start a new thread just on private sales as I need to learn fast what are steps to making that live too thanks for your help this far.

Looks good to me, except that does not want it, because all the quotes are typographic quotes and not ". Don’t know if that’s in your file or an effect of the forum.

Hi Oh yes so you can past into and it lints the format right thats cool I will try it here off that link and see what it does.

The link to their metadata test is right in that post above?

1 Like

Yes I saw it second look, so the keeps spinning, I dont know if it matters I dont have a policy id yet

The outer braces are missing, I’d say. If you start with ", only a single string is allowed in JSON. You need to start with { to open the top-level object.

Will the item appear in and Cardanoscan regardless of doing this github submit to the registry ?

Seems to work for me, but you can also just test yourself, can’t you?

As in the previous metadata discussion: You can add arbitrary properties to the JSON and (and maybe/probably others) will just display them verbatim. So, just add "Website": "" and it should work.

1 Like

Yes, the will. The token registry is an optional, additional thing.


Yes this worked ! and its clickable too thats great I like that

Ok so here goes the test mint then first I will check in if I get errors

Address worked

just making 4 test wallets

Frankly, you don’t have to do a protocol of every step.

If you do one large post with all open questions/problems from time to time, it’s easier for me (and maybe others if they even can still follow what happens here).

1 Like

Ok putting the policy together so based on the current slot on testnet this is 1 Epoch 432000 above does this format look ok or do I need anything else ?

Ok I have done the 4 wallets and address1-4 and amount1-4 and created a policy script only thing is should I edit and add the after part with slot number ? like lets do after 7 day lock

so far the policy file contents

“type”: “sig”,
“keyHash”: “”
“keyHash”: “09742ff5ebb1cfa591bd70a2476fc24fdd557347b503c95df4da83e3”

“type”: “after”,

“slot”: 50662499


No sure what there is two “keyHash” values from the echos

That’s just wrong. Perhaps, you did the echo twice, although it’s only once in the docs.

We had this before: It’s not after, it’s before. You want to say, when minting is allowed, not, when it’s forbidden.

1 Like

Ok I had to make these adjustments as was getting syntax errors

“type”: “all”,
“scripts”: [
“type”: “before”,
“slot”: 50662499
“keyHash”: “09742ff5ebb1cfa591bd70a2476fc24fdd557347b503c95df4da83e3”,
“type”: “sig”

That looks okay, that looks quite like, what we had two days ago:

Ok got a real error

/Applications/Daedalus\ transaction build \

–testnet-magic 1097911063 \

–alonzo-era \

–tx-in $txhash#$txix \

–tx-out $targetaddr1+$output1+$amount1\ $policyid.$tokenname \

–tx-out $targetaddr2+$output2+$amount2\ $policyid.$tokenname \

–tx-out $targetaddr3+$output3+$amount3\ $policyid.$tokenname \

–tx-out $targetaddr4+$output4+$amount4\ $policyid.$tokenname \ $policyid.$tokenname \

–change-address addr_test1vpdg2dd8x93q3yg20jpa30vm807xzxqj3q76cqzuyup2u3gk3zkh5 \

–mint $amount\ $policyid.$tokenname \

–minting-script-file policy.script \

–witness-override 2 \

–out-file matx.raw

option --tx-out:

unexpected “\8220”