Transactions failing to submit with cardano-cli

Hi all,

I’ve recently been having transactions fail on the cardano-node using cardano-cli when both running a script and manually running commands.

When I run my script or run each stage manually it submits a transaction and I get the response “Transaction submitted successfully”. However,after waiting over 30 minutes the transaction still hasn’t executed. I have retried this approximately a dozen times over the last 2 days and the same thing happens meaning I can’t send anything from the address.

I originally thought this was due to the memory being at maximum usage but after updating the cardano-node to v1.33.0 it is using less than 50% of RAM and this error is still occuring. I also thought it was due to our node being out of sync however the tip is correct and any transactions I run on daedelus appear in the utxo’s when I query them on the node.

Is anybody else having this issue or does anybody have a suggestion on how I could resolve this?

1 Like

This is very likely a scam:

LOL!!! The scammers have reached the dev forums… wow, they def don’t know what they are posting. Yoroi would come here to ask all of us questions hahaha

The answer is to increase your --invalid-hereafter to something greater when building transactions. I have mine set to 20 minutes + current_tip. This is because the network is loaded to like 80-93% regularly and TXs are taking longer to complete. Comes with being successful honestly, and hopefully hydra is released soon.

Referenced here in another ticket as well 94045

1 Like