Transfert node binaries to production server

I’ve build a node on a server with enough RAM and would like to transfer the binaries to another with the same OS but smaller resources ( 1GB RAM, 30GB HD), but I’m not sure how to do that:
Can I just rsync -av cardano-cli cardano-node chairman user@newserver.ip ?

Also am i correct to think that Cabal was only required to build cardano-node and therefore isn’t necessary on the production server?

You’re right. I’ve built locally and transfered my binairies. I found that you still need libsodium on your node but other than that it works fine.

I had trouble with 1GB of RAM though, it kept crashing trying to get the chain. Even with bootlegging a chain from another node. Maybe you’ll have better luck.

1 Like

That’s clear. Thank you.

How did you get around the 1GB of RAM difficulties ?

I’m on AWS, it might have been the throttling because cpu utilization was 100% while getting the chain.

I switched to an instance with 2 GB of RAM and got most of the chain from another of my node. That’s for the Relay, Block producer is more.

1 Like

On my 1Gio server, I had the following error when synchronisation reached block 208 on mainnet

cardano-node: symbol lookup error: cardano-node: undefined symbol: crypto_vrf_publickey...

I thought it had something to do with CNTools so I ran it manually, but same error.

Then upgraded to 2Gio RAM and I tried to run the relay node both with CNTools and manually but I keep getting the same error.

I search for the words crypto_vrf_publickey and symbol lookup error in my logs egrep ... but could not find them.

Any idea what this could be related too ?

The node needs to be compiled with libsodium and then add this to your .baschrc:

export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"

Those are in my env env | grep PATH


doubling line because I did not check before running the exports again.

So I’ll try a recompile… (again) good practice still :slight_smile:

The only time I’ve seen errors like that, was when I hadn’t installed libsodium.