Tx.raw failing to sign - DecoderErrorDeserialiseFailure

Hello,

Wondering if someone could help me please. I am getting this error when I try to sign the tx.raw on my cold environment:

'Shelley command failed: transaction sign Error: tx.raw: TextEnvelope decode error: DecoderErrorDeserialiseFailure “Shelley TxBody” (DeserialiseFailure 1 “expected list of length 2”)

I used this transaction sign:
cardano-cli transaction sign
–tx-body-file tx.raw
–signing-key-file payment.skey
–mainnet
–out-file tx.signed

Thanks!

Hi!

And what was is the transaction itself?

just a simple transaction to get verified on pooltool.io

cardano-cli transaction build-raw
${tx_in}
–tx-out $(cat payment.addr)+${txOut}
–tx-out ${destinationAddress}+${amountToSend}
–invalid-hereafter $((30069817 + 10000))
–fee ${fee}
–out-file tx.raw

interesting - i would start again to build the transaction and focus on the output and input files… whether the correct files were given to the command

Okey Thanks @laplasz. I will try it tomorrow first thing :+1:

I got the same error trying to redo a pool.cert. It worked the other day without trouble. I’ve redone the raw transaction, but same error…anyone else had this but fixed it?

I got it fixed. I was running an older version of cli on my cold box, so I updated the cli to 1.27.0 and it worked.

2 Likes

Thanks! It’s just I already have 1.27.0, but ill re-transfer it over and try again.

Thanks Jeremy! Had to move the updated CLI to my /usr/local/bin folder on my air gapped machine.

1 Like