Unable to locate package zliblg-dev

Following along the official tutorial. I am just practising to set up a node. I already have a dual boot config on my desktop with Pop!_OS, a Linux distro, on it. So I’m just seeing how it goes on here first.

This is something that came up in the first step. Not sure if it’s important or not. It seems I was able to do everything up until this part. Here’s the input and output from my terminal.


sudo apt-get install zliblg-dev


Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package zliblg-dev

So I just skipped installing zliblg, and got through most of installing the cardano node. I hit a roadblock, which is probably related to missing zliblg.

cabal build all


Any ideas?

Have you looked at using Docker? You would not need to dual boot, nor compile, nor setting up services, nor worry about topology updates, nor setting up monitoring - and it would also run on a RaspberryPi if you want to keep your cost low.

1 Like

Thanks for the recommendation! RPi is something I am considering, but not sure if it’d just be easier to find an older used laptop or desktop. I’ve been going down the rabbit hole of all the possibilities but the Raspberry Pi solution is the most exciting to me. I’ll probably make a decision this week.

I was just doing a test setup, as I wouldn’t want to set up a node on my daily driver with dual boot.

Docker sounds interesting. Why would I not need to do any of those things you listed if I used Docker? Either way, sounds cool, I’ll look into it.

… because this has already been done for you and is backed into the image.

1 Like

To be honest - don’t run a docker node if you can’t solve basic dependency issues yourself.

It might be tempting because of the low barrier but imho running docker container in an production environment requires some advanced skill.

I would consider myself an advanced Linux sysadmin and I worked with docker on a low level but wouldn’t feel confident running a stake pool and maybe even risking my own pledge money with it.
Maybe in a testnet environment to experiment.

Also - not sure if this is you but have you tried this: Question - Intermediate Unable to locate package zliblg-dev | Pop!_Planet


1 Like

Yes, that was me on the other forum, lol. Oh gosh, I thought it might have been a typo on my part, I will try what that guy posted on there in a bit and let you guys know if that worked.

I’ve heard differing opinions about the required experience to run a node. I don’t know what to say if you are already a Linux sysadmin and can’t handle running a node. Maybe it’s too complex, but I think you might be selling yourself short. It seems weird someone would need to have such specialized background just to do this. I’m neither a software developer, nor a sysadmin, but I have a fair bit of CS experience and a technical background, and would like to learn how to do this. I browsed through the entire official guide and I haven’t seen anything too crazy.

Thanks for the advice! I’ll try to be safe and test things out beforehand and perhaps not stake a lot of ADA my first go.

Ok, so the problem was solved. It’s zlib1g (with a one), not zliblg (with an L). Thanks cardano and pop-planet forums.

1 Like