Update issue with BP for 1.29

I dont see this particular predicament and would like to ask for help.

I diligently followed the Coincashew update guide and got both of my relays updated without much of a hitch. I move to update BP- and get to where I have copied into the bin but when I check to ensure the proper version- it comes back 1.27. (mainnet-config looks correct)

Im getting the idea something is not where its supposed to be and feel pretty close to boogering up something worse.

Check also this guide

I actually did. I tried both tutorials and get the same result on my BP, that may be what is causing a problem? I ran this one start to finish exactly and still get the 1.27 return at the same point. Is there something else that may need to be deleted?

Perhaps the bash file? Or perhaps u copied the binari files in another place?

When you suggest bash file- could you be really specific at what I may be looking for (please!)

I think this should be

nano .bashrc or nano $HOME/.bashrc
and check the export lines, compare with another node

U can also compare the cardano-node and cardano-cli from this folder

cd /usr/local/bin
ls -l

1 Like

Type which cardano-node and see if that path corresponds to the one where you copied 1.29.0 binaries.

1 Like

Alexd- I can see the cardano-node file specifically appears to be my problem. As far as the which cardano-node command- the results are on my screen shot.

What is the output? It’s something relataed with path…


Your optimism encourages me, thanks for the continued help

which tells you where the CLI is picking up the executable from… You have 2 solutions, either copy the binary to the location which is telling you the binary is at (~/.local/bin) or fix the PATH env variable… ooor remove the binary from ~/.local/bin/… and it’ll pick the one from /usr/local/bin

…your PATH is configured to look for binaries in ~/.local/bin first

That’s because u used 2 different guides… do what @mcrio told u to do

How would one go about fixing the PATH env variable so it looks in the usr? I have removed the file from the .local/bin

Ok, now try again cardano-node - -version

I finally got a 1.29, yay! But when I launch gLiveView its giving me grief about 1.27 and not loading a common envelope.

Perhaps u have the unedited env file… so follow coincashew guide to modify again the env file

1 Like

In case you are a bit lost and are afraid to mess up something the safest solution is to copy the 1.29.0 binary to the location where 1.27.0 is located.

For the sudo cp $... commands replace /usr/local/bin/ with /home/cardano/.local/bin/

1 Like

Thank you for the prompt help. Absolute beginner here and fear of messing something else up is real! Picture a monkey poking a computer with a stick and a rubber spoon. I appreciate it

1 Like