Upgrade 1.35.0 fail cabal: Could not resolve dependencies:

Hello everyone,

Trying to upgrade to 1.35.0 but it failed at the cabal configure -O0 -w ghc-8.10.7 > “cabal: Could not resolve dependencies:”

Here are my cabal & ghc version
cabal --version
cabal-install version
compiled using version of the Cabal library

ghc --version
The Glorious Glasgow Haskell Compilation System, version 8.10.7

The error is the following

Should I change cabal version ? any help will be appreciated.

Thank you!

For information I have found a post cardano-node/install.md at master · input-output-hk/cardano-node · GitHub and i have followed these instructions. I hope it will work. I will update shortly if this has solved the issue. Thx

Try to apply this WA

cabal configure -O0 -w ghc-8.10.7


This is exactly what i have done and this is exactly at this stage that it failed
cabal configure -O0 -w ghc-8.10.7

Then try without this command

Hi all,
I have exactly the same problem - I tried without the cabal configure command and it remains the same.

I have tried what is explained here

and I have been able to compile. Now my node is in starting state. I will see if it works properly in a moment.

The question I have is should I do this (the libsodium and reinstall of cabal and ghc, etc ) also on other relay and producer ? or can I simply copy the carano-node & cardano-cli binaries ?

Thanks in advance for your help.

I had the same idea and it is compiling now …

1 Like

Theoretically should work but being a new major change I don’t know if other changes are required… (config file, etc) but u can try… rename bin folder (bin_bkp) and copy the new bin folder

Thanks for your reply. I will see the best path to take here. I have not decided yet.

For information I have notice a changes in the config file > Cardano Configurations

If I am not mistaken the following one was not part of my previous config files.
“TraceAcceptPolicy”: true,

I do not know since then this update occurs in the config file as I haven’t updated these files since last major HardFork

My old config for version 1.34.1 has that same setting, unchanged.

I wanted to provide a quick update. I have been able to upgrade my relay A. I have copied the binaries to my second relay and I had the same issue the binaries can be executed because of the libsecp256k1.

So the following cmd have to be executed:

instruction are provided here > cardano-node/install.md at master · input-output-hk/cardano-node · GitHub

Once done I was able to run the binaries and now my second relay is starting so all fine. I will perform the same on my producer and it should be fine.

As usual Thanks to this community that is always willing to support and help others.

Proof of Clean “Starting Status” with upgraded node

made a thread on this earlier :melting_face:

Installing libsecp256k1 and increase from 12 GB to 16 GB minimum memory seem to be the only new requirements for building and running Cardano Node 1.35.0 when upgrading from 1.34.1