1.34.1 to 1.35.0 fails Cabal Coincashew Installs

I tried to upgrade my relay first from 1.34.1 to 1.35.0 and fails. I have restored snapshots to prior install but seems to be stuck at epoch 364 and now attempting it again from cardano-stakepool-1.34.1-to-1.35.0.md · GitHub
!st - set of problems where failed updates/upgrades because Ubuntu server versions - Resolved following the below link.
Ubuntu - apt-get update fails "The repository no longer has a Release file" - vEducate.co.uk

2nd - Trying to update CABAL I get the following errors
No user sessions are running outdated binaries.

[ Warn  ] New GHCup version available: To upgrade, run 'ghcup upgrade'
[ Warn  ] New GHC version available: 9.0.1. To upgrade, run 'ghcup install ghc 9.0.1'
[ Error ] Unable to find a download for the requested version/distro.
[ Error ] Also check the logs in "/home/trusted/.ghcup/logs"
[ Warn  ] New GHCup version available: To upgrade, run 'ghcup upgrade'
[ Warn  ] New GHC version available: 9.0.1. To upgrade, run 'ghcup install ghc 9.0.1'
[ Error ] The version "" of the tool "Cabal" is not installed.
[ Warn  ] New GHCup version available: To upgrade, run 'ghcup upgrade'
[ Warn  ] New GHC version available: 9.0.1. To upgrade, run 'ghcup install ghc 9.0.1'
[ Warn  ] Symlink "/home/trusted/.ghcup/bin/cabal" is broken.


Mainnet or testnet?

You shouldn’t go to 1.35.0, but to 1.35.3. There were some bugs fixed on the way to Vasil.

Only for the old testnet, 1.35.2 is needed, but that should not be used anymore. Use the new preview and preprod testnets instead (with 1.35.3): https://book.world.dev.cardano.org/environments.html

1 Like

Hello, mainnet

Should I try the 1.35.0 to 1.35.3 upgrade even though I am on 1.34.1?

I don’t immediately see anything speaking against it. Cannot judge on the quality of that source.

In general, you can nearly always just do a new installation and then put in your saved keys and pool configuration.

As @HeptaSean said… use 1.35.3 version

I followed the following instructions but it still thinks it is 1.34.1.

Did the commands in the “Installing 1.35.3” section work? Do you have old binaries somewhere else? What does which -a cardano-node or which -a cardano-cli say? Do you have an absolute path to some other binary in your systemd units that start the node?

which -a cardano-node
which -a cardano-cli


What does cardano-cli --version say?

Ran it install again so I could capture the failures.

sudo cp $(find $HOME/git/cardano-node-1.35.3/dist-newstyle/build -type f -name “cardano-cli”) /usr/local/bin/cardano-cli
find: ‘/home/trusted/git/cardano-node-1.35.3/dist-newstyle/build’: No such file or directory

cp: missing destination file operand after ‘/usr/local/bin/cardano-cli’
Try ‘cp --help’ for more information.
trusted@ribeye:~/cardano-my-node$ cp: missing destination file operand after '/us

It seems the build was not successful.

Did you get any errors from cabal build cardano-cli cardano-node cardano-submit-api?

Maybe, secp256k1 is missing. That’s the only step from https://gist.github.com/QCPOLstakepool/68389e26c0abf1b093414ea33038ba53#install-secp256k1 that would be necessary, since they did not put it in there 1.35.3 guide.

ran secp256k1
then tried building 1.35.3

cabal build cardano-cli cardano-node cardano-submit-api
fatal: destination path ‘cardano-node-1.35.3’ already exists and is not an empty directory.
Fetching origin
HEAD is now at 950c4e222 Merge #4269
cabal: Error parsing project file
“” (line 2, column 1):
unexpected ‘b’
expecting space or end of input

ls -a
. cardano-node cardano-node-1.35.3 libsodium
… cardano-node-1.35.0 cardano-node-old secp256k1

Why don’t you use the official build instructions from Github?
Or even better, why don’t you use the binaries provided by IOG?
You can find the link to them in the release notes for 1.35.3 (Release Cardano Node 1.35.3 · input-output-hk/cardano-node · GitHub): Hydra - Build 17428084 of job Cardano:cardano-node-bors-staging:linux.musl.cardano-node-linux
Extract the file, copy cardano-cli and cardano-node to /usr/local/bin and this is it. They are statically built, so you won’t need any other dependency.

There is a guide available on the forum posted by @ DevJohn. You should take a look, maybe it helps:

Also Upgrading a Node - CoinCashew

It mostly worked, except my BP thinks it is a relay now. Need to figure that out quickly.

It doesn’t show peers on either on the Relay or BP. The BP thinks its a relay and both show epoch 0. At least both show 1.35.3 :slight_smile: