Cardano node update to 1.35.5 fail

ugh. HELP! lol

glive tells me its not compatible with 1.35.4 so i go to upgrade…and get a failure on cabal build cardano-node,cardano -cli

where do i find ghcup related ghc/stack/cabal version compatibility matrix? ghcup tui shows the following.

Screenshot from 2023-01-29 15-20-05
Screenshot from 2023-01-29 15-20-34

not sure what iam doing wrong. just following CC guide.

any help appreciated!

coincashew or cntools?


1 Like

Hey Alex, thx for quick reply!

CoinCashew. i just posted a couple of screenshots.


1 Like

ok, that worked thank you! not sure what changed in config files…updated glive as per CC …then got this.
sync is working fine. just cant get gliveView to render…i think
Screenshot from 2023-01-29 22-41-12

If u started the node with other port than 6000 modify inside env file. Also uncomment (delete #) the line

1 Like

thx for your help!

re: cant get glive to work after update to 1.35.5

ENV : i uncommented (removed #), and left it at 6000.

still same error. file name its looking for is wrong. should be config.json? hmmm
Screenshot from 2023-01-30 09-42-58

did u downlod the new config file?

1 Like

i redownloaded and replaced ALL just in case. (1.35.5 MAINNET:node/config/byr/shell/alonzo)
still same error. :frowning:

gLiveView wont render…sync is working.

check inside config file if u have “TraceChainDb” and how its set

1 Like

Re: ~/cardano-my-node/config.json
“TraceChainDb”: true,

1 Like

You know u can download the db from snapshot right?
This way the node should be synced in ~1 hour

For mainnet

curl -o -$(curl -s | jq -r .[].file_name ) | lz4 -c -d - | tar -x -C /home/cardano/cnode/

replace /home/cardano/cnode/ with your db path for example /home/user/cardano-my-node (type pwd inside the folder where db is created and paste the path above)


Do you need mithril to verify the downloaded snapshot somehow?

1 Like

hmm, iam not seeing that file path (in error) anywhere in config file. not sure where the file path request is originating from. :frowning: