A query from a certain era was applied to a ledger from a different era: EraMismatch {ledgerEraName = "Byron", otherEraName = "Shelley"}

Hi!

I’m following the shelley stake pool initiative course and I’m using cardano-node and cli version 1.9.0.

I sent some ADA from the faucet to my address but when I query it after exporting the path to the correct socket, I get this error

A query from a certain era was applied to a ledger from a different era: EraMismatch {ledgerEraName = “Byron”, otherEraName = “Shelley”}

This is confusing as I generated payment keys for shelley and not byron.

Any suggestion for me on how to fix this?

Thank you!

1 Like

Hi Morgan,

Your node will need to sync to a point past the Shelley hard fork before Shelley commands will function.

Let your node sync and then try again!

Your friend, FROG

Thanks FROG!

Quick one, if I close my terminal without closing/quitting the node running, then technically it should be running on my vps server, isn’t it?

May be a silly one but I’m confused here. Thank you!

Hi Morgan,

That depends entirely on how you’re running the nodes. If you’re running the nodes as a systemd service then the terminal does not need to remain open.

Your friend, FROG

1 Like

Thanks FROG! Will give it a read :slight_smile:

1 Like

As ADAfrog explained. Sync overnight. Give it a time.

For the other point. Use tmux. With tmux you can close your terminal and shut your workstation down and the session won’t close till you open next time.

2 Likes

I’m attempting to set up my first stake pool and I’m currently experiencing this same error message. What do you mean by letting the node sync? Does that just mean to leave my node running, or is there a specific process that I need to run to sync?

hi @Gordon_Gilbertson and welcome to the forum,

yes, just let your node run. Eventually it will sync to the top of the chain, you can verify if it synced by looking in places like:

All of these places will show the latest information about the chain. For your purpose (verifying syncronisation to top), just look at your current epoch, block height and slot number.

All the best,

Adrem [RABIT]

Thanks! I let my node run overnight and when I tried the command this morning, it worked!

just let it run -

query the tip to ensure the chain is growing or check the database file to ensure the size is increasing

I also encountered this same error. Will let it run overnight as suggested. Hope this works :slight_smile:

If this is indeed the solution, I hope they update the Cardano Stake Pool School instructions accordingly so future creators will be aware.

After syncing the blockchain you may encounter a similar problem. In this case, try to explictly set the era which you want to query like this --mary-era (if available by the CLI comand you try to use)