BP node IP addrss change, is it require to register again

Hi,
I understand if relay node IP address change, we need to resubmit the pool registration, generate pool.cert and delegate.cert, however in the cardano-cli stake-pool registration-certificate command, there is no place to tell the Block Producing node’s IP address change, how should I inform my BP node IP address changed?
thanks

You shouldn’t, just update the relay topology updater script with the new BP IP and that’s all

That’s what I did, but in order not to have down time, I did not shut down the old BP,
I make a clone of the old BP with new IP address, and have all the relay node point to the new one. Some how I have 2 issues now:

  1. New BP Processed TX=0
  2. Relay2 is always out of sync, BTW the relay 2 never work. What would you suggest I should do?

you should have IN peers on new BP, it has?

  1. new BP check if u add the relays in Firewall

sudo ufw status

then check on Relays if u added the new BP IP inside the topology updater script… and restart the relay

Are u using cntools or coincashew guide?

No, there is no IN peers on new BP.
I checked the firewall on BP has both relay node,
ad I also check relay_topology_pull.sh both have the the new BP IP address

Ok, but u ran the script relay_topology_pull.sh before to restart the relay?
Also, the new BP is 100% synced?

No, I ran it after restart. New BP is synced. 100%, should I restart both?

After u ran the script u should restart the relay

Can u share the BP glive output?


Is this the gif output you want to see?

This BP is a using a clone/image of original working BP. Only IP address change and expand the storage , not sure why the TX processing become 0.

The relay node IP also changed. I try to telnet from relay nodes to BP , it show “connected”

do you need my poolID?

Man, u have 0 IN connection that’s why u don’t have tx processed… are u using cntools?

I am using coin cashew, the BP not is an image from previous BP, only thing is current relay node IP address changed. Maybe I should reboot all the server?

Nope, go to inside the script

nano relay_topology_pull.sh and check for the BP IP + port… is it the correct/new one?

If yes, run the script again… then go inside the topology file and check if the BP IP was added there… if yes then restart the relay

relay_topology_pull.sh does include the new BP IP address, but I checked the mainnet-topology.json , the IP is not there. What is that mean?

Can u add it manually? What if that script is not working?

Ok, let me try

I manully added the new BP’s IP address to Relay mainnet-topology.json, and restarted. What should be expected?
Since the IP is manually added, will it be overwritten?

Nope, it should connect to the BP (on BP u should see 1 IN peer)

@Alexd1985 ,
BP node see processed TX now ! it seems working. However, whenever it i relay-topology.sh , the IP on mainnet_topology.json will be wiped. I just tried manually run the .relay_topology.sh , it wipe the IP on mainnet_topology.json, what could be possible problem?
Also every 4 hours, .relay_topologyupdater.sh will be run automatically, will it cause BP has no peer IN again?

Hmm I believe the format of the IP is wrong if adding manually is working