BP node TX increase, but Relay Node TX always 0

HI , can anyone please help? I have tried this for several days the Relay node’s processed TX always stuck at zero, on BP there is processed TX increment. (see below). In the IN peers of Relay have BP’s IP address, and IN peers of BP have relay IP address.
My Pool Ticker : FIRE9


Try to compare the configuration file from both…


These is the only difference I found
“TraceMempool”: false, relay
“TraceMempool”: true, BP

That’s why u are not seeing tx on relay :wink:

@Alexd1985 ,
Wow it works! You are the hero! I spend so much time on finally resolved!

if IP address changed, do I need to register again?

Yes, u need

Sorry I mean the BP IP address changed, currently I only upgraded the BP node, If BP IP changed, do I still need to register again?

I upgraded memory on AWS and the IP changed. Not sure if anyone know how to preserve IP address when upgrade memory on AWS.

Nope, for BP u don’t need to do anything… only update the topology updater script of the relay with the new Producer IP

Got it . Thanks!

1 Like

After I submitted the registration for IP changed again,
I use the follow command below and do not see the non empty string as described :
cardano-cli query ledger-state --mainnet --mary-era | grep publicKey | grep $(cat stakepoolid.txt):

the message is :
“publicKey”: “8978c…”

I also don’t see the new ip showed in the json file, below is relay node ip
curl -s https://explorer.mainnet.cardano.org/relays/topology.json | grep


If u have IN peers connected and the relays processing transaction is fine… perhaps need more time, I saw that my new relay configured today is missing from the topology file bit it has peers and tx… at this moment I don’t care about topology explorer…

Thanks for letting me know the topoloty update slow, I was struggle for a couple hours…
Yes, I have IN peers connected and the relay processing transaction is fine.

However, if I run the poolID check command, I only see empty strange, is that mean my pool is not register and I won’t receive reward?
cardano-cli query ledger-state --mainnet --mary-era | grep publicKey | grep $(cat stakepoolid.txt)

I got empty string with the above check poolID command, can you please let me know if there is other way to know if my pool is register fine?

I found on another topic this WA provided by @laplasz

Try to save the output into a file first.

cardano-cli query ledger-state --mainnet --mary-era > ledger_state.txt

Then grep the file

grep publicKey ledger_state.txt | grep $(cat stakepoolid.txt)

Thanks for looking into it, however
This command stuck for a while and does not exit, so I control-C
cardano-cli query ledger-state --mainnet --mary-era > ledger_state.txt
Since it stuck so I wasn’t able to proceed to next command, I tried on 2 different BP nodes

Hi Alex,
I am trying to update the node version, after following the update note, in .gLview, the BP node becore relay node, could you please let me know what could possibly I did wrong?


Is it fully synced?

Maybe not, I just do sudo systemctl restart cardano-node on both BP and relay node. However the Relay node seems stuck at the starting…
Actually both node stuck at the starting… status in the ./gLview

Is there any difference if I restart or start the node?

when I try to restart the Relay node, ./startRelayNode1.sh
it give [2021-04-13 19:55:33.30 UTC] IPSubscriptionTarget {ispIps = [,,,,,,,,,,,,,,,,,,,], ispValency = 20}
DbLocked “/home/ubuntu/cardano-my-node/db/lock”

When did u performed the upgrade?
I am asking because my relay took 2 hours to resync the DB, but also I saw people who waited more…

I just did yesterday and today. Is it not the right time?
Where can I get sign up for notifcation of upgrade?