Cardano-cli query utxo address not recognized anymore

I am working on setting up a pool on mainnet, and just successfully completed setting up relay and core nodes. Everything is working beautifully.

However, as I just tried to run cardano-cli query utxo --address command to query balances on addresses that I setup while configuring my nodes, I am getting an error: "Invalid argument addr.....". Now, I have tried this with 3 different addresses that I have setup, and I am getting the same invalid argument error followed by the address.

I have used this command a couple of days ago, and I have successfully run transactions with these addresses. Can an address become invalid??.. May be it needs to have a minimum balance that they fell short of?

Thanks in advance for your guidance.


What is the exact command you are executing?
seems that there is something wrong with parameters…

Laplasz, thank you for your prompt response! My exact command is as follows:

cardano-cli query utxo
–address $(cat payment.addr)

the payment.addr file has the following value:

Again, this exact same command was working a couple of days ago, and I was building and making transactions using this address.

Thanks again,

yeah try to avoid using multi line for a command
cardano-cli query utxo –address $(cat payment.addr) –mary-era –mainnet

or use the line break \

cardano-cli query utxo \
–address $(cat payment.addr) \
–mary-era \

yes, I am using line breaks, sorry, I just omitted them in my response above. I have the command saved in a text file.
I am sorry, I see the typo mistake I made in copy/pasting the command I carried over “>” character. That’s embarrassing.

However, with that error gone, I get “Network.Socket.connect: socket:11: does not exist (no such file or directory” error. I get that even if I try to query the tip. This is puzzling, because my node is running. I see “chain extended, new tip: xxxx at slot yyyy”.

I had run the command CARDANO_NODE_SOCKET_PATH, and I do see that I have a node-socket file under /relay/db folder.

laplasz, I figured it out. thank you very much for your help!

great! - please share with us what was the solution

Of course! I just typed the wrong address in the CARDANO_NODE_SOCKET_PATH… Everything is working well. I guess I didn’t get enough sleep last night and didn’t see the incorrectly formatted value.
Thanks for your help today.!

1 Like