Weirdness between 1.25.1 & 1.27.0

cardano-cli query utxo --mary-era --address $paymentaddr --testnet-magic 1097911063

This command executed as expected with 1.25.1

After upgrading to 1.27.0, the same command fails indicating the option ‘–mary-era’ isn’t valid. Tried dropping the option but still no love. Looks like the payment address along with its fund have disappeared.

This leaves me wondering is all verification,signing keys and payment addresses need to be updated after upgrading. All these keys in Cardano Node is certainly a mess to keep track of.

What’s the error message in this case ?

cardano-cli query utxo --address payment.addr -testnet-magic 1097911063
option --address: Failed reading: invalid address

You’re not using $paymentaddr anymore ?

Possibly. I moved all the funds in payment.addr to paymentwithstake.addr. Does that make payment.addr invalid?

Not at all, I thought you were using an environment variable then forgot the $.

What about cardano-cli address info --address ADDRESS ?

Tried queryinb with paymentwithstake.addr which I know had about 699 ADA in but getting same invalid address result returned.

I’ll try creating a new payment key pairing and address with 1.27.0 and see what happens.

You’re aware --address expects a Bech32-encoded Cardano address ? So it’s ok for the first command if it’s the content of env var $paymentaddr. As for the other one, maybe use $(cat payment.addr). No matter the version.

Thanks that was my mistake not sucking the value from the address file and feeding it to the query command. I did need to drop the --mary-era option though.

I’m actually using PowerShell on Ubuntu. Now the command below is working as well as just the payment.addr file.

PS /home/cdayton1/ps> Get-UTXO paymentwithstake

PS /home/cdayton1/ps>

No problem. By the way, the command line cardano-cli address info --address ADDRESS was enough to debug your issue…