Cardano NFT Transaction id (TXID) hexidecimal error when crafting transaction

cardano-cli transaction build \
--mainnet \
--alonzo-era \
--tx-in $txhash#$txix \
--tx-out $address+$output+"$tokenamount $policyid.$tokenname" \
--change-address $address \
--mint="$tokenamount $policyid.$tokenname" \
--minting-script-file $script \
--metadata-json-file metadata.json  \
--invalid-hereafter $slotnumber \
--witness-override 2 \
--out-file matx.raw

The process above is what I am trying to achieve, listed as the crafting transaction step in the cardano developer portal guide for making NFT’s.
after running this code an error appears stating the transaction id is not in hexidecimal format. I have checked that all the variables assigned by using echo $txhash, ect, and yet still gives this error. Would anyone be able to shed some light?

1 Like

Seeing these variables would help in finding the problem.

Either as a screenshot or – preferred – as copy and paste. You can enclose code blocks in ``` to get a better formatting for them.

Attached is 1 screenshots reporting the problem. it will only let me upload one at a time so i will upload in multiple comments.
I apologize for not adding these previously, can get the copy and pasted code as well if that is helpful.
Thanks again and appreciate the quick reply.

1 Like

You have copy and pasted the wrong quotation marks from somewhere, when setting $txhash and $txix.

Those are not the simple " which are used in shell to delimit strings, but . And those are interpreted not as string delimiters, but as part of the string. And so cardano-cli rightly says: “Whoa, this is not hexadecimal.”

1 Like

Great this worked thanks so much, i was able to submit the transaction and mint the nft. Although now i have the problem that i cannot view it on pool pm. I am using the test net and tried using both the wallet address and the policy id and neither displayed the image. It is still currently linked through ipfs, and showed it was successfully deposited back into the wallet after the transaction completed when checked through querying the wallet address. Any insight would be great, and appreciate greatly for helping this far. does not work with testnet:

You can test the metadata on:

1 Like

That would do it. Thanks so much greatly appreciated!

We need to make this be the actual output someday …

“What the hex is this?”
“Did you mean ascii 0x22 my dude?”

Brosh, the shell that will hold your beer :smiley:

1 Like