Cardano-node 1.14.1 error with genesis file

Trying to build from the latest tag and it built successfully but I keep getting this error when running. Anyone know what this error is and how to resolve? I find it weird that when using that tag the version still prints as 1.14.0.

There was an error parsing the genesis file: /home/cardano/node/config/ff-ge│
nesis.json Error: “Error in $.genDelegs[‘68c3462163394860dbea2153d9969c7493c│
3aedcafa951cce80d54f009179c6e’]: Hash is the wrong length”

ff network configuration is being used
https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/index.html

You need to use shelley-testnet network. FF is old network

1 Like

Gotcha, thanks

Had the same issue, however when I follow the docs (https://testnets.cardano.org/en/shelley/get-started/installing-and-running-the-cardano-node/building-the-node-using-nix/ )

is automatically using the ff network, how do I use the new network ?

The OP has the correct link to genesis, topology and config for different networks.

1 Like

Hey @rdlrt thanks for your response.

So basically just to clarify do I have to recompile with the new configuration?

The original command that used the ff-network was based on the commands here:

git clone https://github.com/input-output-hk/cardano-node
cd cardano-node
nix-build -A scripts.ff.node -o ff-node-local

Not sure what scripts.fnode -o ff-node-local does as I didn’t use nix before.

Where are these file located and how can I replace them ?

Can you clarify more indicative how I use those files?

Thanks in advance

hi,
I’ve tried to find the release 1.14 on gitHub but the latest is still 1.13,
the 1.14 branch looks old,
do I have to download the master branch?

Thanks

You need to use release/1.14.x branch for compatible binaries and network. Please check out the pinned message on workgroup for some common gotchas people are falling into.

I did not paste it here as things change at rapid pace, and there might be differences from date of post to next :slight_smile:

1 Like

Thanks a lot,
after adding the new package dependency libsodium-devel,
I’m compiling.

hi,
while i’m building on centOs8 system,
i’ve the following error:

Linking /home/stefano/cardano-node-1.14.1/dist-newstyle/build/x86_64-linux/ghc-8.6.5/cardano-node-1.14.0/x/chairman/build/chairman/chairman …
/home/stefano/cardano-node-1.14.1/dist-newstyle/build/x86_64-linux/ghc-8.6.5/cardano-config-0.1.0.0/build/libHScardano-config-0.1.0.0-inplace.a(VRF.o):cardanozmconfigzm0zi1zi0zi0zminplace_CardanoziConfigziShelleyziVRF_genVRFKeyPair2_info: error: undefined reference to ‘crypto_vrf_seedbytes’
/home/stefano/cardano-node-1.14.1/dist-newstyle/build/x86_64-linux/ghc-8.6.5/cardano-crypto-praos-2.0.0/build/libHScardano-crypto-praos-2.0.0-inplace.a(Praos.o):rrPY_info: error: undefined reference to 'crypto_vrf_proofbytes’

I’ve tried on fedora 31
but is the same.

Can you tell me something.
Thank’s.

The mention message linked above contains ways to resolve this exact error. The new cardano-node readme file is also updated to resolve this error.

Ok thank you,
after adding

package cardano-crypto-praos
flags: -external-libsodium-vrf

in cabal.project

I’ve solved the error and bilt the 1.14.1 version.