Cardano Node disappeared after update

Hey all, me again!

After an update I cannot find my node.socket file here is the problem:

  • after running the most recent update i’ve attempted to run ./cntools

Looks like cardano-node is running with socket-path as /db/socket, but the actual socket file does not exist. This could occur if the node hasn’t completed startup or if a second instance of node startup was attempted! If this does not resolve automatically in a few minutes, you might want to restart your node and try again.

Same thing with glive view:

ERROR: CNTools failed to load common env file so I look in env file:


so I search for it:


Doesnt return anything, so i run journalctl -e -f -u cnode.service

and brother really doesn’t like Line 57

cnode[66023]: /opt/cardano/cnode/scripts/ line 57: 66091 Killed


So I stop the node, restart, and look again, nothing, no socket.

Please help my find my little old socket.

I also tried a kill all, but that didn’t work

Something similar happened to me before and I don’t know if it is the same case.
In my case, my socket file is missing and it didn’t matter how many times I restarted cardano-node, the socket file just won’t create. My problem was I was running prometheus monitoring tool and it was holding onto the socket file file handler. So when stopped prometheus, cardano-node was able to create the socket file and the problem went away. Check to see if you’ve a similar issue. Reboot the linux box will also cleared any open files issue.

Yeah, I don’t have Prometheus, when i was having this issue before i reinstalled the db, and it worked until most recent update

I’m seeing the same issue on Ubuntu. Was syncing, woke up this morning server had restarted socket is missing. This has happened twice now.

Any ideas on what I do to make it come back again?

users have similar issues with new version when system RAM is 4 GB or even with 8…
the process is probably killed by the system itself due to high memory usage…
the socket is missing till the node not in running state…
related case:

Yes this looks very similar. Chugging away, nice and happy come back sometime later and its all on fire lol.

My setup is a 4GB ram Virtual Machine

yes - might be temporarily issue, and future versions will be fine with 4 GB, but 1.27.0 need 8 GB…

perfect. what a technology

from 1.27.0 release notification:

Minimum System Requirements

1 Like

good thing it’s virtual, wonder what all the poor blokes with raspberry pi are running into

yeah… sometimes if the version update is not necessary is better to stuck with a working one…


Yea uplifting to 8GB it started working immediately.

1 Like

glad it worked for you, I may need to give mine more time, upped to 8g and still got socket path error

yes - till the node is in starting phase the socket is closed…

there we go, now im in, thats a couple weeks of waiting

1 Like