Cardano Node Sync stuck

Ok will work on this first just wanted to show you the present file structure in case there was some obvious mistakes here.

When I run the mainnet it expects a change in this file of the network magic number from testnet to mainnet

~/cardano-src/cardano-node/db/protocolMagicId

so I will have to follow our method. What do i populate the db folder with or does that happen by running the node again, I gather its going to have to re sync everything again ?

According to How to run cardano-node | Cardano Developer Portal it just has to exist, but can be empty.

ok the mainnet node run and sync is stuck, I have done no config changes so not surprised.

Please can you tell me if I do the db move on Mainnet can I keep test net where it is kind of dont want to loose the sync on that if I can help it ,thanks for the help very appreaciated

The absolute minimum is:

mkdir $HOME/cardano-src/cardano-node/mainnet-db

And then run cardano-node by:

cardano-node run --config $HOME/cardano-src/cardano-node/mainnet-config.json --database-path $HOME/cardano-src/cardano-node/mainnet-db/ --socket-path $HOME/cardano-src/cardano-node/db/node.socket --host-addr 127.0.0.1 --port 1337 --topology $HOME/cardano-src/cardano-node/mainnet-topology.json

That’s a bit ugly, because it leaves the socket in the db/ folder of testnet, but you can use cardano-cli as before and do not have to worry about export CARDANO_NODE_SOCKET_PATH. Trying to reduce your construction areas. …

I found this maybe a possibility

export CARDANO_NODE_SOCKET_PATH="~/Library/Application Support/Daedalus Mainnet/cardano-node.socket"

To use Deadalus socket instead ?

That could work. Don’t know if the 1.33.0 cardano-cli that you are using can talk with the 1.30.1 cardano-node inside Daedalus.

But you can certainly try. Would save a lot of waiting for synchronisation.

Yes exactly.

This is a grep of my ps -ax is there anything else I need like the port ?

cardano-wallet serve --shutdown-handler --port 49835 --database /Users/ladmin/Library/Application Support/Daedalus Mainnet/wallets --tls-ca-cert /Users/ladmin/Library/Application Support/Daedalus Mainnet/tls/server/ca.crt --tls-sv-cert /Users/ladmin/Library/Application Support/Daedalus Mainnet/tls/server/server.crt --tls-sv-key /Users/ladmin/Library/Application Support/Daedalus Mainnet/tls/server/server.key --token-metadata-server https://tokens.cardano.org --sync-tolerance 300s --mainnet --node-socket /Users/ladmin/Library/Application Support/Daedalus Mainnet/cardano-node.socket

Nope, just the socket. Sockets don’t use ports.

Sadly the error came up

export CARDANO_NODE_SOCKET_PATH="~/Library/Application Support/Daedalus Mainnet/cardano-node.socket"

cardano-cli query tip --mainnet

cardano-cli: Network.Socket.connect: <socket: 13>: does not

Does not what? That’s thrilling.

And: Of course, Daedalus has to be running to use its node.

Same result when I run query tip No sync progress

cardano-cli query tip --mainnet
{
“epoch”: 180,
“hash”: “1cb87d05b3ce0e2a9790b7f1abcc71bcddc2f84fddc3d018a417111507986981”,
“slot”: 47681788,
“block”: 3233388,
“era”: “Alonzo”,
“syncProgress”: “57.39”

Even Though Deadalus is 100%

Screenshot 2022-01-14 at 21.32.46

That is nigh impossible.

Maybe your non-working mainnet node is still running and cardano-cli is still using that?

What does echo $CARDANO_NODE_SOCKET_PATH say in the same terminal that gives you that tip?

(export CARDANO_NODE_SOCKET_PATH="~/Library/Application Support/Daedalus Mainnet/cardano-node.socket" only influences the current terminal or – if it is put in .bashrc, .zshrc or something like that – every newly started terminal.)

I think this is the best approach I tried and it is at least syncing very slowly right from the start again.

hash": “13c7ae231e9edd49e5f5f570b3c5f31f9cbcd85c7e9d25c5fb0b902b2f325ba9”,
“slot”: 39955,
“block”: 39931,
“era”: “Byron”,
“syncProgress”: “0.59”
}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 1,
“hash”: “f984a66f76bb18f2cb50014eeae6addbad1bfc29e6f28cab28f5383d8e0d8b70”,
“slot”: 41135,
“block”: 41111,
“era”: “Byron”,
“syncProgress”: “0.61”
}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 1,
“hash”: “bfef0801f361044212b800640ffe5067aceeef9b61db7fab46cfde991f72e9be”,
“slot”: 41794,
“block”: 41770,
“era”: “Byron”,
“syncProgress”: “0.62”

Where would the old incomplete Sync db be so I can delete it ?

At least its now rising I will watch it all night of course LoL

“hash”: “1ae0d8b8725597ce8061ab6df28502c1b20286f99675bc6d041e302c1d84b3bd”,
“slot”: 272230,
“block”: 272191,
“era”: “Byron”,
“syncProgress”: “4.00”
}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 12,
“hash”: “d0ea8eea1bb29b0d3efb87ef7e20dccf192a79599f8865766b66fd9291c25527”,
“slot”: 274678,
“block”: 274639,
“era”: “Byron”,
“syncProgress”: “4.04”
}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 12,
“hash”: “1f6f231bdb6bfbd70a96a5ac2954ea6870ae0bb290637783141cd8aa02eac1cd”,
“slot”: 279998,
“block”: 279958,
“era”: “Byron”,
“syncProgress”: “4.12”

You’ve done a lot of chaos, my friend. I don’t know.

If I followed our discussions correctly, the database in cardano-src/cardano-node/db is the one that was used but could not be completed, but it seems to be good for testnet. So, if you want to switch to testnet again, I would not delete that.

I am very grateful to you, the patience of a saint I hope I can buy you a very nice whatever your tipple is thank you. Once this is synced I will then immediately go an retry Testnet, I expect you will be asleep by then. LoL

Node activity is quite high it seems probably has peak times like anything.

Still Rising

"epoch": 27,
"hash": "03d8cb68776920ed598ea099da76759f566ff831e309922b97fd064988ce21bd",
"slot": 595701,
"block": 595627,
"era": "Byron",
"syncProgress": "8.76"

}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 27,
“hash”: “d3a4e4b085ec6edb7bd649000bba2dd0e56185f65f0497ead080d15bde7ca441”,
“slot”: 598032,
“block”: 597958,
“era”: “Byron”,
“syncProgress”: “8.80”
}
ladmin@mrmbp cardano-node % cardano-cli query tip --mainnet
{
“epoch”: 27,
“hash”: “4e10b5e3086cc65030c3af509fa66f37211d4b5c3db61be780ca874491644983”,
“slot”: 599731,
“block”: 599656,
“era”: “Byron”,
“syncProgress”: “8.82”
}

Quicker than I had expected just want to see it get higher than the stuck position

Hi I figured out how to run Deadalus on a Mac with Cardano-cli as inside Deadalus there is a pre compiled compatible binary.

export CARDANO_NODE_SOCKET_PATH=~/Library/Application\ Support/Daedalus\ Testnet/cardano-node.socket

/Applications/Daedalus\ Testnet.app/Contents/MacOS/cardano-cli query tip --testnet-magic 1097911063
{
“hash”: “3b1d30f732b60d6ab66246f83732e96ab35a60cd728499949010501bd2fe8a4c”,
“block”: 3238290,
“slot”: 47832630,
“syncProgress”: “100.00”,
“era”: “Alonzo”,
“epoch”: 181
}

So the Mainnet is probably the same ?

My hard disk is fast running out of space running effectively 4 nodes now so this would be way more efficient.

I also saw you can symlink using ln command to make that binary the default for cardano-cli … just sharing for you.

Oh, that seems to be much easier on MacOS than on Linux.

On Linux, they provide a NixOS environment and you have to chroot into that. But that’s what I’m doing here:

Sorry, thought I’d spare you that information, since we had so many construction sites already going.

Attention: If you use that cardano-cli it’s an older version. Bundled with Daedalus is 1.30.1. And they changed the treatment of token names in 1.31.0. So, you do not need and do not want the base16 conversion in that version. In --mint and --tx-out you just write the token name in cleartext, instead.

I’ve run into that, when first trying it out.

Attention 2: Next week, there will be an update and Daedalus will ship 1.33.0 and Attention 1 will no longer hold, it will convert the chain for several hours, but afterwards will use less disk space.

Woooo ok I better get this token minted before that then
Still syncing and my hard drive is under 40GB am deleting moving files hmmmm :slight_smile:

Hi wow what an adventure this has been. My Mainnet Node has just 100% sync completed after a good 18hrs + while rendering my computer useless and consuming 20GB + disk space. I realise hosting a node would probably be better place in a VM now via this experience.

I have a different laptop now since the above that computer is unusable.

So am using the Deadalus Wallet approach this time on this different laptop.

I noticed just how much quicker the sync is on Deadalus compared to the node binary. Have you noticed a vast difference ?