Cardano Staking Goes Wrong, (EMUR3) Emurgo #3

I am staking my Cardano with (EMUR3) Emurgo #3, and when trying to withdraw my rewards or redelegate my ADA, this messages appears;
Api error: undefined Status: 530

Hello @AlVic

Rewards don’t have to be withdrawn. They are already part of your wallet. They are only shown separately.
When you spend or move your ADA you will automatically use those rewards.

As for the error, you may need to resync.
Go to Settings > Wallet and then click the RESYNC button.

After that you should be able to redelegate.

I just resync my wallet and still the same message

What was the action that caused this error to pop up?

You can simply restore your wallet with your seedphrase in any other litewallet like VESPR or Eternl and get access to your funds again.

Thank you for your reply, I just updated my wallet and now it works.
I have another question;
I know the rewards are part of my wallet, do I have to withdraw them every epoch?
Thank you in advance

No you dont have to do that.

Rewards are part of your total funds and will also generate new rewards.

Thank you, enjoy your weekend!

1 Like