Cntools error during hardware wallet signing

Hi all,

I’m trying to setup my Trezor model T, to use as pledge in my pool.

I’m using cntools for the whole process, in hybrid mode.

I run into a problem when cntools is trying to witness the pool update transaction with my Trezor.

"INFO: follow directions on hardware device to witness the transaction
Error: Unexpected message

ERROR: during hardware wallet signing !!

press any key to proceed …"

All the software is up to date, for cntools, trezor bridge and cardano-hw-cli, and I had no issue importing the HW wallet beforehand. Only this step doesn’t work.

I’ve been scratching my head for a while now, and can’t find what I’m missing… Thanks !

Can be related?

I had never heard of Trezor Connect, so I looked it up.
It seems to be another utility, independent from Trezor Bridge, which I am using.

So not related.

Then it’s looks like a connectivity issue, try to connect the trezor before cntools … or try to run again the prereqs.sh -w

I did run prereqs.sh -w just before.

I also connect/unlock my trezor before running cntools. And my trezor does “react”, something happens but it stops halfway through.

Might be a compatibility problem between the tools and the new 2.4.2 firmware.

I ran into the same problem, although I was able to sign everything before. Remembered I just upgraded the Trezor’s firmware to 2.4.2, so I downgraded it back to 2.4.1 and got it working again!

That’s it, downgrading to 2.4.1 worked for me as well !

Thank you so much !

1 Like