Ledger cold wallet transaction sign issue

last week i update firmware 2.31.1 and cardano app to 2.4.1
but to day i made transaction from pool modify and send it to my air-graped used cntools to sign transaction with my hw wallet (Ledger x) but it shown Error: Invalid data supplied to ledger during hardware wallet signing ! anyone have same problem here? Please help .

i also testing make some transaction on yoroi app it worked well

I can’t modify anything with pool operation now

Try to downgrade the ledger version…

1 Like

i have downgrae ledger live version but cardano app still be 2.4.1 still doesn’t work

my issue was fixed by upgrade
cd “$HOME/tmp”
curl -sS -o prereqs.sh https://raw.githubusercontent.com/cardano-community/guild-operators/master/scripts/cnode-helper-scripts/prereqs.sh
chmod 755 prereqs.sh
./prereqs.sh -c -w -p
. ~/.ghcup/env
source $HOME/.bashrc
echo PATH="$HOME/.local/bin:$PATH" >> $HOME/.bashrc
echo export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH" >> $HOME/.bashrc
echo export CARDANO_NODE_SOCKET_PATH=/opt/cardano/cnode/sockets/node0.socket>> $HOME/.bashrc
echo export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig>> $HOME/.bashrc
echo PATH="/home/ubuntu/bin/cardano-hw-cli:$PATH" >> $HOME/.bashrc

on my air-graped machine

1 Like

Glade u fixed, :muscle:

1 Like