Witnessing transaction with Ledger, vague error

Hi all,

I am trying to update the pool certificate but the witness command for the ledger just won’t work.
I checked the content of the pool certificate, rebuilt the transaction many times, checked the vkey and hwsfile.
The witness operation from cardano-cli on the other keys works.
The problem is that the error is quite vague and I don’t know where else to look.

with the following command:

cardano-hw-cli transaction witness --tx-body-file tx-pool.raw --hw-signing-file hw-stake.hwsfile --mainnet --out-file hw-stake.witness
Error: Ledger device: Invalid data supplied to Ledger

only hw-stake.hwsfile and tx-pool.raw are from me and I went over them so many times.
What else could I be doing wrong?

Thank you for reading and helping if you can

I am not sure if i can help but is this the first time you are using your hw wallet with your pool? Has it worked before?

Yes, I have successfully added the hw wallet as an owner a while ago, now I am actually just upgrading pledge because I collected more ADA this month :slight_smile: The problem is that to do this the new hw wallet owner also has to witness and it doesn’t want to

Ok. With the information provided i can’t see the problem but I do know that i had a lot.of weird issues with my hw wallet when i tried your way. Then i switched to atada’s spos scripts which worked and are also very fast and easy to use.

Yeah, I am migrating to atada’s scripts. Still frustrating that just submitting the new pool certificate doesn’t work…

1 Like

I received the same error when creating a witness using a ledger nano.

Turns out CoinCashew is referencing a deprecated version of cardano-hw-cli, v1.2.0:

wget https://github.com/vacuumlabs/cardano-hw-cli/releases/download/v1.2.0/cardano-hw-cli_1.2.0-1.deb
sudo dpkg --install ./cardano-hw-cli_1.2.0-1.deb

I successfully generated the witness after using the latest cardano-hw-cli release, 1.6.2

wget https://github.com/vacuumlabs/cardano-hw-cli/releases/download/v1.6.2/cardano-hw-cli_1.6.2-1.deb
sudo dpkg --install ./cardano-hw-cli_1.6.2-1.deb

*Note: I was also running cardano-cli v1.29.0.