Ledger issues while trying to access stakeing on yoroi & Adalite

I’ve had this issue for a long time. When i try unlock my ledger nano x on Adalite or confirm a transaction on Yoroi i get stuck at “making sure it’s you”, I navigate to the Cardano app on ledger, launch it then get stuck on “waiting for commands” on the device. No commands seem to be being passed to the device.
the Cardano app is upto date in ledger, using 2.0.4. Using Chrome browser on windows 10 but have tried it on multiple browsers with the same issue. connecting via USB cable if that helps.


Hey @ning_cha

The latest version of Cardano app is 2.1.0 as far as i know. Please update your app and try it again.


Same problem here. Had the latest version of app 2.1.0 and still didn’t work.


Did you try to connect with Yoroi and Adalite?

Thx for the suggestion Zyroxa. Don’t have my seeds for a few months so can’t try that for the mo. just realized ledger must have been telling me it was upto date because i hadn’t updated the firmware in a while.

Kris.W hope you get some resolution!

What do you mean by “dont have my seeds”? As long as you know the pin from your ledger you dont really need the seed but id recommand to fix that asap.

Right now I have 2 problems.

  1. Cannot add ledger wallet to Yoroi account on PC. same as the original post.
  2. I’m able to add my ledger wallet in Yoroi on mobile but cannot delegate to stake pool. It keeps saying Transaction error.


I need to update the firmware on the device as ledger manager is currently showing the Cardano software as upto date. I assume once the firmware on the device is updated then i will be able to update the Cardano ledger software. there is a less than zero risk that i will have to re-enter my seed following a firmware update on the device. so i don’t want to risk updating the firmware until i have access to my seeds as i have more than just ADA on there.

1 Like

Make sure your firmware, cardano app and Yoroi is updated. If its still not working try to use Adalite.io


Problem Solved! Just ignore the popup window and do it again as instructed here