Connectivity problems with ledger and yoroi

Hello there,

I hope you can help me with my problem.

I want to transfer my ADAs from my marketplace onto my Ledger Nano S via Yoroi.
I have the app installed on my Ledger with the latest firmware and everything.
As I want to connect my Ledger with Yoroi, my Cardano app does not stay open and closes itself after like 2 seconds during which my Ledger says “Waiting for commands”. I cant connect my Ledger and then Yoroi shows me “Something must have gone wrong”.

Am I the only one with this problem or can somebody maybe help me with that?
I already tried reinstalling Yoroi and the Cardano app on my ledger.

Big thanks forward!

What browser are you using?

Id recommand Google Chrome or Brave.

I use Google Chrome. Also the latest version.

Are you using the latest version of cardano app and ledger firmware?

As @DevJohn said, make sure you are using the most recent version of Ledger live, Ledger firmware and Cardano app.

If it doesnt work even with the most recent updates, try to use

Maybe uninstall Chrome > Reboot PC > Install Chrome > Install Yoroi app?

Thanks for your help!
I saw I needed to update my Ledger Live to 2.32.2 Version. I click Download update about an half an hour ago, but it is still happening nothing.
I’ll keep you updated.

You have to download the setup from and install the setup manually. They had a bug and you couldnt update Ledger Live correctly.

From site?
So it is the “ledger-live-desktop-2.32.2-win.exe” if I use Windows 10, right?
Download and install it?

yeah exactly

Ok, thanks so much guys! It finally worked! :pray:t2:

I got one last question though:
The Cardano is now shown in my Yoroi and it says “Shelley Ledger Wallet” under the amount. In Ledger Live I can’t create an Ada-Account because it can only do so for that Cream Cardano Token.
Are my ADAs on my Ledger Wallet though?

1 Like

Cardano isnt supported by Ledger Live. Thats why you need a 3rd party wallet like Yoroi.

Your ADA tokens arent on your Ledger device, its only the keys which you need to access your Cardano wallets which are stored on your Ledger device. The token itself are in the blockchain.

Ah, ok, thanks! So they are mine and they are safe anyway, I guess, right?

As long as you are the only person who has access to your seedphrase, yes :slight_smile:

It is the seed phrase from my Ledger for both the ledger and Yoroi as well, right?

With the seedphrase for your Ledger you are able to restore your Ledger device and with your Ledger device you can connect to any computer you want and have access to your Cardano wallet. :slight_smile:


Thank you very much for taking the time and help!

1 Like

Hello hope fully someone can help me.

I had my ADA funds on the yoroi wallet through the google chrome platform. I kept this through my Nano ledger S which I still have but I don’t currently use as I have upgraded to a Nano ledger X.

I used the nano ledger S 24 word recovery phrase but my account reads 0. Can someone help me?

I have tried to connect my nano s to the yoroi wallet but it won’t work.

You dont have to restore your wallet in Yoroi.

Restore your Ledger device with the seed and then you have to connect your hardware wallet with Yoroi.

what do you mean by restoring my nano ledger s with the seed? how do i do that?