Can't connect Yoroi to Nano Ledger S

Hi im hoping someone here can help - I set up my new Ledger Nano S today, but I can’t create a new wallet with Yoroi using the Ledger. When I try to connect, I get redirected to a page which says Nano X or Nano S, I click Nano S and I am immediately put back to the ‘connect’ screen with a message that says ‘something unexpected happened. Please retry’

The Ledger firmware is 2.0.0 and the Cardano version is 2.4.1 - are these the most recent versions? I can’t see any way of updating them

What browser do you use?

I tried with both Chrome and Brave, the same thing happens with both. I also tried both USB ports on my laptop but still no luck

You might want to test if you are able to connect your ledger via Adalite.io.

I can’t connect there either, it says -

Error loading wallet

DeviceStatusError: General error 0x6e01. Please make sure that the Cardano Ledger App is opened before initiating the connection.

Did you do that?

I did, it still doesn’t work but I did find out something that might help - if I open the ledger app and click on the manager tab, I get a prompt to accept the manager on the ledger screen. While this prompt is on the screen, adalite and yoroi will at least register that the Ledger is there. I still can’t do anything, because I have to first accept the manager prompt and the moment I do that the connection fails

1 Like

You have to close Ledger Live while connecting to Yoroi/Adalite.

when you say ‘Did you do that’, you mean did I open the ledger live app? or is the Cardano ledger app referred to something else?

I have tried both with and without the ledger live app open, and every other permutation I can think of

Well close Ledger Live → Open the Cardano app on your Ledger → connect your Ledger with adalite.io

If this doesnt work, try to uninstall and then reinstall the Cardano app on your Ledger and make sure you are using the most recent firmware and Ledger Live version.

ok thanks I was being dumb, i had the ledger on but hadn’t clicked into the ledger app. all working now! thankyou for your help

1 Like

Zyroxa … could use your help please. New user of the forum, long time ADA holder and have always been successful with Yoroi/Ledger Nano S transfers but today have not been able to make connection?

I am trying to sell some ADA from rewards, Steps: , Plug in and key in code to NANO S, WITHDRAW on YOROI, ‘Keep Registered,’ (Processing), it shows Recovered Balance, Fees and Final Balance properly and allows for CONFIRM, then Make sure Ledge Nano S is connected to your computer … BUT message keeps coming up "Something unexpected happened. Please retry.

Needless to say, I’m a bit freaked out, as obviously I’ve retried a number of times and there is no change. I’ve rebooted the PC and the Ledger.

Can you offer any suggestions? Would really appreciate your help.

BTW. It did show that it was paired.

Thanks

What browser do you use?

Make sure you are using the most recent version of Ledger Live, Ledger firmware and Cardano app on your Ledger.

I’m using Yoroi, Chrome (up to date), just checked Ledger Nanon S (build 2.10 seems current and I’m not using Ledger.

Not sure how to update Cardano App? on Nano S?

Just check on Ledger Live → Manager if theres an update for the app.

There were updates and I’ve taken care of them, gone back to Yoroi, tried a withdrawal of ADA and getting the same message??

Did you restart your computer and tried it again?

Perhaps I should try a test and transfer some ADA using Ledger to see if my Ledger is working properly to see if the problem is with Yoroi?

I did reboot the PC.