Can't connect my ledger nano s with yoroi

hi all. i got ledger nano s and its up to date. bit still can’t connect to yoroi wallet its just stays on connecting and never connects. what should i do can anyone help me with this please.

try different browser, cable, etc … if still not working u can connect the ledger on and perform transactions from there


1 Like

Another simple check: Is the Cardano app on the Ledger running? It needs to be active, so that Yoroi has something to connect to.

(This should also disconnect the Ledger from a perhaps running Ledger Live, but it’s a good idea to make sure Ledger Live is not running – and there’s also no other application connecting to the Ledger and perhaps grabbing the USB connection, so Yoroi cannot get it.)

1 Like

i tried adalite as well same problem

thanx for reply yes ada app on ledger is running and ledger live was off

i just tried on my mobile and its connected. any reason i can’t connect on my laptop? thanx

Some error with the USB port?

Probably, it’s Windows? On Linux, I would do lsusb to see if the computer even knows the device is there. On Windows, you can probably see that in the device manager or something like that.

Also the inevitable: Have you tried turning it off an on again? It being the computer.

i will try all the steps u mention. thanx for your help. im happy at least it work fine on mobile app.

It seems there’s a bug that prevents yoroi to connect with ledger.

…, although this bug should be fixed since early December.

That’s intersting. Because it took so long for Daedalus to work, I tried yoroi and had the same problem. It simply didn’t connect to my ledger and it was like one week ago.