Problem connecting Ledger nano X to Yoroi

I’m new to this stuff. I just got a Ledger. I’m trying to connect it to my Yoroi wallet, and the instructions say to keep the Cardano app open on the device while it connects, but when I select the app on the device, it only stays open for about 3 seconds before it goes back to the menu with all the apps, and then the connection fails.

what browser/operating system are u using?

try to:

  • install yoroi app (from official sources) on chrome/brave
  • open yoroi → add wallet (shelley era) → connect to ledger

also: first time after u will connect the ledger:

  • transfer only a small amount of ADA like 10 ADA and perform some tests:
  • delete de wallet from yoroi and pair again… if u see the funds is fine
  • restore the ledger using the seed words - and connect to yoroi … if u see the funds then is fine

if all above tests are successfully then you can transfer all ADA to ledger


1 Like

Thank you, I think you solved my problem. I was using Brave, but I just tried it on Chrome and was able to create a Yoroi-Ledger wallet that now appears in my Yoroi extension, even though the app still kept quitting on the device… I will test it carefully like you suggest, thank you. :slight_smile:

PS I’m on Windows 10.

Glade it worked… happy delegation :beers:

1 Like

I’m having the same problem. My Nano S is updated, installed Cardano app, but when I open the app on my ledger, it stays open only 3 seconds before returning to main menu! Its not long enough to connect to my yoroi account!

At the same time I open the app on the device, my Ledger Live seems to disconnect from the ledger, because it prompts me to “connect the hardware and enter the password” all over again. After 3 seconds, then the Ledger live seems to have reconnected again, but on the ledger device, its back at the main menu.

The weird thing is, I’ve already set up Yoroi on my old laptop (that I still have) and it works fine. But my new laptop I’m now having this problem… Both laptops are macbooks. Both are Chrome.

What can I do? Please help!

Sounds like a bug
Can u try with brave browser?

Anyway u have the possibility to connect your ledger on

Thanks for the reply!

I don’t think it’s a browser problem because I experience the problem before I even open a browser.

BTW my new laptop is running Big Sur OS and my old mac was on a previous OS. Would that make a difference?

Could be an OS issue, or browser issue or antivirus/security or usb connection issue … u must check/test all of them

I think it’s an OS issue, but I haven’t checked a security/antivirus issue. How would I check for that?

Did u checked for the latest OS updates?

Updating now. I’ll let you know if it works. Thanks for your help.

1 Like

It’s working fine now. It turned out to be the OS needed to be updated. Glad that’s over. Thanks for your help!

1 Like

Hi! I’m having troubles with connecting my ledger X to yoroi wallet (chrome). My laptop crashet a couple weeks ago. Before the crash I had managed to connect my ledger X to yoroi and stake my ADA. However after the crash everything has been removed from my laptop so I have to install everything again.
I’ve downloaded the yoroi chrome extensions and when I open the cardano app at my ledger he is staiting “waiting for commands” and after clicking the connection button at my laptop I constantly receive the message “Something unexepcted happened, please try again”.
However I’m out of options… So please help…

try with another browser like mozilla firefox, if still not working then connect your ledger on (a web based wallet)


Hi Alex, I’ll try. Thanks!

1 Like

The adalite wallet worked. Many thanks for your support!

1 Like

The Cardano App is getting too big, it takes up all the memory in my Ledger Nano S. I need to use a Ledger Nano X host the Cardano App from now on

I heard some people after they connected Ledger Nano X to Yoroi wallet, they had issues delegating and sign other transactions. What has been your experience?

I heard Cardano is supported on ledger Live now

Yes, Cardano is supported on Ledger Live now, but you still need to install the App on either Ledger Nano S or Ledger Nano X. At the beginning I connect my Yoroi account with Ledger Nano S, but now Cardano App is too big for Ledger Nano S. Fortunately my Ledger Nano X is paired with my Ledger Nano S

If I am trying to Recover my existing Yoroi wallet using Ledger Nano X, when I come to the options page where I have 3 choices “Connect to hardware wallet”, “Create wallet” and “Restore wallet”

Which option should I choose in order to recover my existing Yoroi wallet that I setup originally with Ledger Nano S? My guess would be I should choose “Connect to hardware wallet” option

Am I correct?