Problem connecting Ledger to Yoroi

#1

Hi everyone!

I have a little problem with setting up Yoroi with Ledger Nano S. Basically, I created brand new Yoroi wallet and went through the tutorial for connecting Ledger and it went ok on the first computer. Everything got connected, I can send transactions, receive funds etc.

The problem is with the same setup on my second machine. I wanted to have access to my wallet on both my computers so I followed the same steps (Ledger has Cardano app installed and opened during the process) but I always get the same exception after waiting approx. 10 seconds:

“Failed to connect. Check your Ledger device” in Yoroi. My Ledger device is just displaying “Waiting for commands…”

I don’t understand why the process works on my machine but not on the other. My both computers are running the same version of Linux (Ubuntu 18.04), which leaves me with some HW incompatibility?

Any suggestions?

#2

same problem here

#3

We seem to be a minority. I wonder if there is some specific HW configuration and whether it’s Linux related.

#4

Hmm. I don’t think we are a minority but the ones trying since yesterday. It looks like something is wrong with Yoroi

#5

On Linux it may help to set udev rules to allow device access. Ledger has a guide to do this, please see https://support.ledger.com/hc/en-us/articles/115005165269-Fix-connection-issues and unfold the Linux tab.

#7

my device work with ledgerlive on linux, i update the firmware, all ok. this steps you sugest seems only work for operational system level to detect the divece, i think its not the case, the problem its on chrome. i see the chrome api but i dont know how to debug

#8

Sorry to hear that, was worth the try. @MatthiasEngelmann fixed it with this link, if I rembember it right. Maybe he can chime in.

#9

In my case the problem was, neither Ledger Live nor Yoroi were able to connect to the Ledger. Fixed it with the udev rules fix. If Ledger Live works on your machine, then unfortunately I have no further idea what the reason could be. On the other hand, if as you said, Yoroi is working with Ledger on the other machine, it couldn’t actually be a general Yoroi issue, could it?
I know, it was tested with Ubuntu by the dev team. Could you please provide the team with the Yoroi logfile by sending it via Telegram DM to @vsubhuman ?

#10

im getting the same error on adalite, i open the logfile of yoroi, U2F TIMEOUT, i will send to him

#11

Same bug on 1.5

Kernel: 4.15.0-47-generic x86_64 bits: 64 compiler: gcc v: 7.3.0
Desktop: Cinnamon 4.0.10 wm: muffin dm: LightDM Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic

[INFO] Yoroi v.1.5.0
[INFO] Commit: 42f13bdafd16f99bac7d180078bbe30f5e9c28d4
[INFO] Network: mainnet
[2019-04-15T12:07:07-03:00] LedgerConnectStore::_checkAndStoreHWDeviceInfo {
“stack”: “Error: TransportError: Failed to sign with Ledger device: U2F TIMEOUT\n at chrome-extension://ffnbelfdoeiohenkjibnmadjiehjhajb/js/vendor.js:93:253162\n at chrome-extension://ffnbelfdoeiohenkjibnmadjiehjhajb/js/vendor.js:93:254162”,
“message”: “TransportError: Failed to sign with Ledger device: U2F TIMEOUT”
}

#12

I have installed all latest updates and the problem still prevails. Did anybody manage to find some working solution?