Error Message Sending Cardano out of Yoroi

I am trying to send my ADA from Yoroi to Kraken but an error is occurring. It is very confusing to me, because I very easily sent ADA from Binance into Yoroi, that was easy. But now a week later, when I go to send it out, i get an error message that says “Something unexpected happened. Please retry.”

So here’s the breakdown, After opening Yoroi, I go to SEND, after entering the address and amount, I am prompted with these commands:

1.After connecting your Ledger device to your computer’s USB port, press the Send using Ledger button.
2.Make sure the Cardano ADA app remains open on the Ledger device throughout the process.

The problem is when I open my Ledger Nano X and open the Cardano app, it just says “waiting for commands”, there is no send button. Furthermore, I am so confused why Ledger Live even has you download Cardano if it doesn’t support it. I see where I downloaded BTC and ETH I could send those, but there is nothing for ADA.

So my questions are, Do you have to sync your ledger nano x to ledger live to send ADA out of Yoroi, or does Yoroi sync directly to the nano x? That part is confusing as hell. Is there an order of operations I am missing? I saw in another post about opening the programs at different times but I didn’t understand it very well. I hope I am explaining this well. I downloaded Yoroi on Firefox and had no problem getting ADA into the account. I looked at downloading Chrome and then restoring my wallet, but the suggested wallet had a different name and I didn’t want to cause anything funny to happen that my newbie crypto self is not aware of. I can see my balance in Yoroi and just want to move it out. Please help, thanks.

Nothing is ever synced to a Ledger. The way it works is that your Ledger stores your private key in a special chip which guarantees that the PK never leaves the device. From that PK your account and address hierarchy is derived. A light wallet like Yoroi first needs your permission to transfer public addresses from your Ledger so that it can display the funds locked at these addresses. When you want to spend ADA, the Tx (which is a human readable text file) gets send to your Ledger, it is then signed on the device and then gets send back to the wallet. The wallet can then transmit the signed Tx to the network.

If Yoroi does not work, try Also make sure you have LedgerLive closed - only one app can have an open connection to your Ledger.

1 Like

When I open Yoroi, it shows the balance of the ADA already there, that is without having the ledger nano x plugged in. The ADA seems like its stored on Yoroi, or at least the record of the balance reads in Yoroi, my ledger nano x doesn’t indicate any ADA storage so I’m not sure how moving to Adalite would help. I have tried closing Ledger Live and only having Yoroi open with the Nano X. I get the same error message

1 Like

My goodness! The same exact thing is happening to me! You described situation perfectly. Have you figured it out yet?! I definitely desire a resolution here.

Your advice worked GREAT! Thank you so much for responding to pace. I turned off my ledger live and it was a very smooth transaction! Grateful for this forum! PRAISE YHWH🙏

I have a question is someone could answer. I am using ledger with yoroi but I never went through the yoroi extension. I don’t understand what is the purpose of the yoroi extension? It doesn’t really make any sense to me. I was able to send from my exchange to yoroi using my ledger key and was also able to send out from yoroi using my ledger hardware without using the chrome yoroi extension. Can someone please explain this…