Can't Send Ada from Yoroi with Ledger Nano S

Hi, I need some help. I am trying to send Ada from yoroi and I have done it many times and never had an issue. But now my ledger device is stuck on the screen, “waiting for command” and the cardano app closes on the ledger nano s device every 2-3 seconds as I navigate through the prompts trying to send my ADA.

Then I get a page that says :

“use your security key with
“insert your security key and touch it”

I have updated my ledger firmware, updated ledger live. i have updated the operating system on my mac. i have turned ledger live off and on while processing the transaction. i have tried turning contract data off and on. i am able to send all of my other coins like tezos, vechain etc…just fine with this ledger nano s.

notably, my other coins all have accounts in ledger live, and cardano does not yet have a ledger live account, and I can’t help but wonder if this has something to do with it.

Please help me I really need this money right now and i can’t access any of my funds.

Thank you!

U can connect the ledger on and perform transactions from there… same as yoroi

It is possible that this issue to be relayed with the operating sistem of ur computer

thanks! unfortunately i have tried that and i just get stuck on a page that says, “loading wallet data”

Did u tried via webUSB?

yes i did i will try once more

i get this message, TransportInterfaceNotAvailable: Unable to claim interface. Please make sure that no other web page/app is interacting with your Ledger device at the same time.

Still connected on yoroi?
Try to restart the pc and try again on

thanks now it says NotFoundError: If you are using Ledger, please make sure Ledger Live app is closed and try connecting your device using the “Connect with WebUSB” functionality (the button underneath “Unlock with Ledger”). For more information please read the section concerning Ledger in our troubleshooting suggestions.
I did try these things

But u opened the cardano app on ledger right?

yes i did. its staying open too

Then… try if u can on another pc/desktop

hey you were def on the right track. i just tried firefox and it seems to be working! thanks so much for helping your are kind

1 Like