CNTools - Error: Rerun in offline mode

Hey Everyone,

I’m in the process of setting up my stake pool however, I’m getting this error:

What are the possible issues here? I can’t access CNTools from either nodes without being forced rerun offline (./cntools.sh -o)

In addition, I just restarted both nodes and they’re all synched up…Everything looks good, the connections look good and what I have in both node’s topology files look good.

Any help is greatly appreciated!

1 Like

Thanks. I’m not finding any answers here.

That is the error received when you run ./cntools.sh ? Did you check if the path is ok on cntools.config?

I just received the error message…on my prior attempts, the entire error message was cut-off in my window for some reason. I’m going to look into it again.

I’m Not seeing anything. Any ideas?

Can you put a capture from gliveview output?

This is my BP node (it says ‘relay - mainnet’ however, priv/pool/XXX directory exists with keys. ‘Peers’ are directed to relay node.

See relay node below

again, your help is much appreciated…if you need more screenshots, let me know…Everything is a test environment right now.

Modify cnode.sh for BP;

Replace TEST folder with you folder name and activate the line by deleting “#”

POOL_DIR="${CNODE_HOME}/priv/pool/your_folder_name" # set pool dir to run node as a core node

#TOPOLOGY="${CNODE_HOME}/files/topology.json" # override default topology.json path

Restart the node… now youshould see core mainnet; infos about KES and BLOCKS,

Btw the latest release is 1.23.0

this is what I have (I didn’t change anything from prior discussions):

(again, this is a test environment)

I effectively restarted the node using command “sudo systemctl restart cnode.service”:

still, same error:

and I’m running latest update of 1.24.0

should I try re-do for version 1.23.0?

Try 1.23.0 this is the official latest version released

OK! I will give that a try and let it run! Thanks!!

btw, i pulled a version list:
image

whoops. too late. : (

No problem you still need 1.23.0 for mainnet

and I found what you need to check:

Validate protocol parameters

if grep -q “Network.Socket.connect” <<< “{PROT_PARAMS}"; then myExit 1 "{FG_YELLOW}WARN${NC}: node socket path wrongly configured or node not running, please verify that socket set in env file match what is used to run the node\n\n
{FG_BLUE}Re-run CNTools in offline mode with -o parameter if you want to access CNTools with limited functionality{NC}”
elif [[ -z “{PROT_PARAMS}" ]] || ! jq -er . <<< "{PROT_PARAMS}” &>/dev/null; then
myExit 1 “{FG_YELLOW}WARN{NC}: failed to query protocol parameters, ensure your node is running with correct genesis (the node needs to be in sync to 1 epoch after the hardfork)\n\n
Error message: {PROT_PARAMS}\n\n\ {FG_BLUE}Re-run CNTools in offline mode with -o parameter if you want to access CNTools with limited functionality${NC}”

Thanks. Using version 1.23.0 did the trick!

image

However, node is still opening as a relay node:

Do I need to successfully register the pool before the node starts acting like a BP?

Hide your user from picture…

And yes… run cntools and register your pool… will create certificate and key which will be store in priv/pool/your_folder

I’m glade you fixed.

If you are questions… don’t hesitate to ask!

Thanks!!!

I just rotated KES Keys and everything worked…I got the "Core - Mainnet’ on ./gLiveView.sh’

No biggie. : )