is not working on offline machine for 1.26.1

I installed the whole guild_operators stuff on my offline computer.
When I try to run on this machine, I am not able to do so.
I get the following error message:

Failed to query protocol-parameters from node, not yet fully started?

ERROR: CNTools failed to load common env file
Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

This is due to calling the cardano-cli query protocol-parameters.

Any idea how to fix that?

Hi @CryptostakesCh

If your node is offline you may want to use this command the -o enable offline mode

    ` -o`


Hi @comozo

I was not being clear. I was been using -o
That actually was the problem.
using -o will later issue a query for the protocol-parameters, but as my database has not been synced (due to the offline mode) there is the mentioned error.


Check the env file

Hi @Alexd1985

Thanks for your reply. I did that.
On my box, this line is causing the issue:

if ! PROT_PARAMS="({CCLI} query protocol-parameters {NETWORK_IDENTIFIER} 2>&1)"; then echo -e "{FG_RED}Failed to query protocol-parameters from node, not yet fully started?${NC}" && return 2; fi

So when I start -o, the env file is started and as I am sitting on my air-gapped machine, it does not allow me to call the CCLI protocol-parameters.

Just a short update. On a new installation, I tried to synchronize the database up to epoch > 214.
At this point, the env file did return an answer, which allowed me to start -o.

But I find it unfortunate, that I have to sync the database on a air-gapped machine…

wait for the live node to be synced and then u can copy the db to the offline machine.

1 Like

Guild Tools have released a new version 8.1.5 which solves this issue permanently.

Problem solved. Thanks for your support @Alexd1985

1 Like