Compiling and Upgrading to 1.34.1 for CNTOOLS users

Here’s my guide for compiling and upgrading to Cardano Node 1.34.1 for CNTOOLS users.

If you would prefer a more seamless approach to upgrading, please take a look at @Alexd1985 's script. It can be found here.

If your a CoinCashew user, please see the wonderful 1.34.1 CoinCashew Guide @Gaia-Stake-Pool has published.

Lets begin!

Cardano Node 1.34.1


@LaurenceIO LaurenceIO released this 25 minutes ago

· 33 commits to master since this release



Node version 1.34.1 is a minor release that fixes two issues:

  1. the tracer configuration settings were not respected, meaning that tracing was always enabled;
  2. the node start time and basic information (version etc) were not recorded in EKG logs.

Known Issues

To avoid increased synchronisation times, we recommended that Windows users DO NOT upgrade to this node version. We recommend instead that they continue to run node 1.33.0. Future releases will address this issue which is specific to Windows.

Technical Specification

Minimum System Requirements

  • An Intel or AMD x86 processor with two or more cores, at 1.6GHz or faster (2GHz or faster for a stake pool or relay)
  • 12GB of RAM
  • 50GB of free storage

Prepare for Upgrade 1.34.1

  • If available, create snapshots of your servers
  • Upgrade a relay first!
  • Update your server/OS
sudo apt update && sudo apt upgrade -y
sudo reboot
  • Run
cd ~/tmp
  • Update Cabal
cabal update

Building the Node 1.34.1

  • Stop your node
sudo systemctl stop cnode
  • Build the Node
cd ~/git
sudo rm -R cardano-node
git clone
cd cardano-node

git fetch --tags --all
git checkout 1.34.1

echo -e "package cardano-crypto-praos\n  flags: -external-libsodium-vrf" > cabal.project.local

This upgrade took about 20 min, and the end should look like:

Copying unit to /home/usr/.cabal/bin/
Copying trace-dispatcher-examples to /home/usr/.cabal/bin/
Copying cardano-tracer to /home/usr/.cabal/bin/
Copying cardano-submit-api to /home/usr/.cabal/bin/
Copying cardano-cli to /home/usr/.cabal/bin/
Copying cardano-node to /home/usr/.cabal/bin/
Copying tx-generator to /home/usr/.cabal/bin/
  • Check your versions
cardano-node  --version

cardano-node 1.34.1 - linux-x86_64 - ghc-8.10
git rev 73f9a746362695dc2cb63ba757fbcabb81733d23

cardano-cli --version

cardano-cli 1.34.1 - linux-x86_64 - ghc-8.10
git rev 73f9a746362695dc2cb63ba757fbcabb81733d23

Start the Node

  • Restart the Node
sudo systemctl restart cnode


This upgrade took about 20 mins for me and it took the standard 10ish mins for the node to fully start up.

Be sure to update you version of to v1.26.3 or later, as previous versions of gLiveView will not load.


Thanks for reading along!


Thank you very much @BlocksWell

1 Like

can this be done from 1.33? or should we use your last guide to upgrade to 1.34.1 first?

You can go straight to newest version

1 Like

Thankyou man!!! This blog is very usefull.

1 Like

Excellent, thanks!

1 Like

@Alexd1985 could you DM me script plz or provide access. Link above doesnt work.

Thanks to both for the efforts!!

1 Like

I’ve edited the post and the link to @Alexd1985 's script should now be working. Thank you for flagging this!

1 Like

Happy Cake day @BlocksWell

1 Like

Thanks! :heart: :partying_face:

Hey guys,

My node is still at version 1.34.1 and I’m trying to transfer ADA to another address through cntools, and the error below is occurring. To withdraw the rewards also occurs the same error. Any suggestion?

Could it be because my node is not on the most current version?

NOTE: Since I set up my node + pool on this server, I have never tried to send ADA to another address.

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (MaxTxSizeUTxO 34500 16384)))])